summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf/qoriq-atf_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/atf/qoriq-atf_2.3.bb')
-rw-r--r--recipes-bsp/atf/qoriq-atf_2.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/atf/qoriq-atf_2.3.bb b/recipes-bsp/atf/qoriq-atf_2.3.bb
index aed32851..f2922c91 100644
--- a/recipes-bsp/atf/qoriq-atf_2.3.bb
+++ b/recipes-bsp/atf/qoriq-atf_2.3.bb
@@ -47,7 +47,7 @@ do_compile() {
47 if [ "${NXP_COT}" = "true" -a "${ARM_COT}" = "true" ]; then 47 if [ "${NXP_COT}" = "true" -a "${ARM_COT}" = "true" ]; then
48 bbfatal " \ 48 bbfatal " \
49 Error!, Both ARM CoT and NXP CoT are enabled. Only one CoT is built in a yocto build, \ 49 Error!, Both ARM CoT and NXP CoT are enabled. Only one CoT is built in a yocto build, \
50 Don't add nxp-cot and arm-cot into DISTRO_FEATURES_append at the same time." 50 Don't add nxp-cot and arm-cot into DISTRO_FEATURES:append at the same time."
51 fi 51 fi
52 52
53 if [ "${NXP_COT}" = "true" ]; then 53 if [ "${NXP_COT}" = "true" ]; then
@@ -160,7 +160,7 @@ do_install() {
160 160
161do_deploy() { 161do_deploy() {
162 if [ "${ARM_COT}" = "true" ]; then 162 if [ "${ARM_COT}" = "true" ]; then
163 outputdir="atf_arm-cot" 163 outputdir="atf:arm-cot"
164 elif [ "${NXP_COT}" = "true" ]; then 164 elif [ "${NXP_COT}" = "true" ]; then
165 outputdir="atf_nxp-cot" 165 outputdir="atf_nxp-cot"
166 else 166 else
@@ -171,5 +171,5 @@ do_deploy() {
171 cp -fr ${D}/boot/atf/* ${DEPLOYDIR}/${outputdir}/ 171 cp -fr ${D}/boot/atf/* ${DEPLOYDIR}/${outputdir}/
172} 172}
173addtask deploy after do_install 173addtask deploy after do_install
174FILES_${PN} += "/boot" 174FILES:${PN} += "/boot"
175COMPATIBLE_MACHINE = "(lx2160a|lx2162a)" 175COMPATIBLE_MACHINE = "(lx2160a|lx2162a)"