summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf/qoriq-atf_1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/atf/qoriq-atf_1.5.bb')
-rw-r--r--recipes-bsp/atf/qoriq-atf_1.5.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-bsp/atf/qoriq-atf_1.5.bb b/recipes-bsp/atf/qoriq-atf_1.5.bb
index 19208334..f2657726 100644
--- a/recipes-bsp/atf/qoriq-atf_1.5.bb
+++ b/recipes-bsp/atf/qoriq-atf_1.5.bb
@@ -8,7 +8,7 @@ PV = "1.5+git${SRCPV}"
8inherit deploy 8inherit deploy
9 9
10DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native" 10DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native mbedtls rcw cst-native"
11DEPENDS_append_lx2160a = " ddr-phy" 11DEPENDS:append:lx2160a = " ddr-phy"
12do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" 12do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
@@ -21,12 +21,12 @@ COMPATIBLE_MACHINE = "(qoriq)"
21PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
22 22
23PLATFORM = "${MACHINE}" 23PLATFORM = "${MACHINE}"
24PLATFORM_ls1088ardb-pb = "ls1088ardb" 24PLATFORM:ls1088ardb-pb = "ls1088ardb"
25PLATFORM_ADDITIONAL_TARGET ??= "" 25PLATFORM_ADDITIONAL_TARGET ??= ""
26PLATFORM_ADDITIONAL_TARGET_ls1012afrwy = "ls1012afrwy_512mb" 26PLATFORM_ADDITIONAL_TARGET:ls1012afrwy = "ls1012afrwy_512mb"
27 27
28RCW_FOLDER ?= "${MACHINE}" 28RCW_FOLDER ?= "${MACHINE}"
29RCW_FOLDER_ls1088ardb-pb = "ls1088ardb" 29RCW_FOLDER:ls1088ardb-pb = "ls1088ardb"
30 30
31# requires CROSS_COMPILE set by hand as there is no configure script 31# requires CROSS_COMPILE set by hand as there is no configure script
32export CROSS_COMPILE="${TARGET_PREFIX}" 32export CROSS_COMPILE="${TARGET_PREFIX}"
@@ -56,16 +56,16 @@ PACKAGECONFIG[optee] = ",,optee-os-qoriq"
56uboot_boot_sec ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa-secure-boot" 56uboot_boot_sec ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa-secure-boot"
57uboot_boot ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa" 57uboot_boot ?= "${DEPLOY_DIR_IMAGE}/u-boot.bin-tfa"
58rcw ?= "" 58rcw ?= ""
59rcw_ls1012a = "_default" 59rcw:ls1012a = "_default"
60rcwsec ?= "_sben" 60rcwsec ?= "_sben"
61 61
62chassistype ?= "ls2088_1088" 62chassistype ?= "ls2088_1088"
63chassistype_ls1012a = "ls104x_1012" 63chassistype:ls1012a = "ls104x_1012"
64chassistype_ls1043a = "ls104x_1012" 64chassistype:ls1043a = "ls104x_1012"
65chassistype_ls1046a = "ls104x_1012" 65chassistype:ls1046a = "ls104x_1012"
66 66
67ddrphyopt ?= "" 67ddrphyopt ?= ""
68ddrphyopt_lx2160a = "fip_ddr_sec" 68ddrphyopt:lx2160a = "fip_ddr_sec"
69 69
70do_configure[noexec] = "1" 70do_configure[noexec] = "1"
71 71
@@ -242,5 +242,5 @@ do_deploy() {
242 fi 242 fi
243} 243}
244addtask deploy after do_install 244addtask deploy after do_install
245FILES_${PN} += "/boot" 245FILES:${PN} += "/boot"
246BBCLASSEXTEND = "native nativesdk" 246BBCLASSEXTEND = "native nativesdk"