summaryrefslogtreecommitdiffstats
path: root/openembedded-layer/recipes-kernel/asf/asf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded-layer/recipes-kernel/asf/asf_git.bb')
-rw-r--r--openembedded-layer/recipes-kernel/asf/asf_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/asf/asf_git.bb b/openembedded-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 00000000..7cf8f57a
--- /dev/null
+++ b/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
7SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
8
9inherit module
10
11S = "${WORKDIR}/git/asfmodule"
12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18do_configure[depends] += "virtual/kernel:do_shared_workdir"
19do_configure_prepend () {
20 find ${S} -name Makefile -exec \
21 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
22}
23
24do_install(){
25 mkdir -p ${D}/${libexecdir}
26 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
27 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
28 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/../scripts ${D}/${libexecdir}/
30}
31
32FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
33RDEPENDS_${PN} += "ipsec-tools"