summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch19
-rw-r--r--recipes-devtools/utp-com/utp-com_git.bb5
2 files changed, 2 insertions, 22 deletions
diff --git a/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch b/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch
deleted file mode 100644
index 5db050c1..00000000
--- a/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1--- a/makefile
2+++ b/makefile
3@@ -1,10 +1,12 @@
4-CC=gcc
5-CFLAGS=-I. -Wall -O2
6-DEPS=
7+CC ?= gcc
8+CFLAGS ?= -I. -Wall -O2
9+LDFLAGS ?=
10+DEPS ?=
11+
12 OBJ=utp_com.o
13
14 %.o: %.c $(DEPS)
15 $(CC) -c -o $@ $< $(CFLAGS)
16
17 utp_com: $(OBJ)
18- gcc -o $@ $^ $(CFLAGS)
19+ $(CC) -o $@ $^ $(LDFLAGS)
diff --git a/recipes-devtools/utp-com/utp-com_git.bb b/recipes-devtools/utp-com/utp-com_git.bb
index 163f5852..db2d7f08 100644
--- a/recipes-devtools/utp-com/utp-com_git.bb
+++ b/recipes-devtools/utp-com/utp-com_git.bb
@@ -4,10 +4,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
4 4
5DEPENDS = "sg3-utils" 5DEPENDS = "sg3-utils"
6 6
7SRCREV = "7fe590fef812561cceb08aaa10b64e9bac8f542f" 7SRCREV = "dee512ced1e9367d223d22f10797fbf9aeacfab6"
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/ixonos/utp_com;protocol=https \ 9 git://github.com/Freescale/utp_com;protocol=https \
10 file://0001-Fix-Makefile-for-crosscompilation.patch \
11" 10"
12 11
13PV = "1.0+git${SRCPV}" 12PV = "1.0+git${SRCPV}"