summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq.inc12
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb2
2 files changed, 11 insertions, 3 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq.inc b/recipes-connectivity/openssl/openssl-qoriq.inc
index ee02fb79..bcbf36f2 100644
--- a/recipes-connectivity/openssl/openssl-qoriq.inc
+++ b/recipes-connectivity/openssl/openssl-qoriq.inc
@@ -8,6 +8,17 @@ SECTION = "libs/network"
8LICENSE = "openssl" 8LICENSE = "openssl"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" 9LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10 10
11PROVIDES = "openssl"
12
13python() {
14 pkgs = d.getVar('PACKAGES', True).split()
15 for p in pkgs:
16 if 'openssl-qoriq' in p:
17 d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
18 d.appendVar("RCONFLICTS_%s" % p, p.replace('openssl-qoriq', 'openssl'))
19 d.appendVar("RREPLACES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
20}
21
11DEPENDS = "perl-native-runtime" 22DEPENDS = "perl-native-runtime"
12 23
13SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \ 24SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
@@ -170,4 +181,3 @@ do_install () {
170} 181}
171 182
172BBCLASSEXTEND = "native nativesdk" 183BBCLASSEXTEND = "native nativesdk"
173
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
index 16736fb9..3b9d56eb 100644
--- a/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.0.1i.bb
@@ -10,8 +10,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
10export DIRS = "crypto ssl apps engines" 10export DIRS = "crypto ssl apps engines"
11export OE_LDFLAGS="${LDFLAGS}" 11export OE_LDFLAGS="${LDFLAGS}"
12 12
13PROVIDES = "openssl"
14
15SRC_URI += "file://configure-targets.patch \ 13SRC_URI += "file://configure-targets.patch \
16 file://shared-libs.patch \ 14 file://shared-libs.patch \
17 file://oe-ldflags.patch \ 15 file://oe-ldflags.patch \