summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/qoriq-base.inc4
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-1.11.inc21
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.11.bb5
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.11.bb10
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.11.bb8
-rw-r--r--recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch66
-rw-r--r--recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch24
7 files changed, 0 insertions, 138 deletions
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc
index e982f370..e482b857 100644
--- a/conf/machine/include/qoriq-base.inc
+++ b/conf/machine/include/qoriq-base.inc
@@ -1,7 +1,4 @@
1# common providers of QorIQ targets 1# common providers of QorIQ targets
2PREFERRED_PROVIDER_cryptodev-linux = "cryptodev-qoriq-linux"
3PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module"
4PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests"
5PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq" 2PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq"
6PREFERRED_PROVIDER_virtual/bootloader ?= "${PREFERRED_PROVIDER_u-boot}" 3PREFERRED_PROVIDER_virtual/bootloader ?= "${PREFERRED_PROVIDER_u-boot}"
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq" 4PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq"
@@ -35,6 +32,5 @@ MACHINE_SOCARCH_SUFFIX ?= ""
35MACHINE_SOCARCH_SUFFIX_qoriq = "-qoriq" 32MACHINE_SOCARCH_SUFFIX_qoriq = "-qoriq"
36 33
37MACHINE_ARCH_FILTER = "virtual/kernel" 34MACHINE_ARCH_FILTER = "virtual/kernel"
38MACHINE_SOCARCH_FILTER_append_qoriq = " cryptodev-qoriq-linux cryptodev-qoriq-module cryptodev-qoriq-test"
39 35
40INHERIT += "fsl-dynamic-packagearch" 36INHERIT += "fsl-dynamic-packagearch"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-1.11.inc b/recipes-kernel/cryptodev/cryptodev-qoriq-1.11.inc
deleted file mode 100644
index 72fb6a68..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-1.11.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1HOMEPAGE = "http://cryptodev-linux.org/"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6python() {
7 d.appendVar('PROVIDES', ' ' + d.getVar('BPN').replace('-qoriq', ''))
8 pkgs = d.getVar('PACKAGES').split()
9 for p in pkgs:
10 if '-qoriq' in p:
11 d.appendVar("RPROVIDES_" + p, ' ' + p.replace('-qoriq', ''))
12 d.appendVar("RCONFLICTS_" + p, ' ' + p.replace('-qoriq', ''))
13 d.appendVar("RREPLACES_" + p, ' ' + p.replace('-qoriq', ''))
14}
15
16SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cryptodev-linux;protocol=https;nobranch=1"
17SRCREV = "fabe5989a3dc9fba0cd0a40b612247cdde351c01"
18
19S = "${WORKDIR}/git"
20
21CLEANBROKEN = "1"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.11.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.11.bb
deleted file mode 100644
index c2cbc71b..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.11.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require recipes-kernel/cryptodev/cryptodev-linux_${PV}.bb
2require cryptodev-qoriq-${PV}.inc
3
4BBCLASSEXTEND = ""
5COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.11.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.11.bb
deleted file mode 100644
index 86078c57..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.11.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require recipes-kernel/cryptodev/cryptodev-module_${PV}.bb
2require cryptodev-qoriq-${PV}.inc
3
4inherit qoriq_build_64bit_kernel
5
6SRC_URI += " \
7file://0001-Disable-installing-header-file-provided-by-another-p.patch \
8"
9
10COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.11.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.11.bb
deleted file mode 100644
index 784c38b7..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.11.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require recipes-kernel/cryptodev/cryptodev-tests_${PV}.bb
2require cryptodev-qoriq-${PV}.inc
3
4SRC_URI += " \
5file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
6"
7
8COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
deleted file mode 100644
index 84fd27e6..00000000
--- a/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
+++ /dev/null
@@ -1,66 +0,0 @@
1From 1980a8f4779a955e73285e7a0d86549b69bea5c8 Mon Sep 17 00:00:00 2001
2From: Yu Zongchun <b40527@freescale.com>
3Date: Sun, 28 Apr 2013 14:39:22 +0800
4Subject: [PATCH] Add the compile and install rules for cryptodev tests folder
5
6This is required to install the cryptodev tests folder to rootfs
7
8Signed-off-by: Yu Zongchun <b40527@freescale.com>
9
10Upstream-Status: Pending
11
12---
13 Makefile | 6 ++++++
14 tests/Makefile | 8 ++++++++
15 2 files changed, 14 insertions(+), 0 deletions(-)
16
17Index: git/Makefile
18===================================================================
19--- git.orig/Makefile
20+++ git/Makefile
21@@ -35,6 +35,9 @@ modules_install:
22 $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
23 install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
24
25+install_tests:
26+ make -C tests install DESTDIR=$(PREFIX)
27+
28 clean:
29 $(MAKE) $(KERNEL_MAKE_OPTS) clean
30 rm -f $(hostprogs) *~
31@@ -43,6 +46,9 @@ clean:
32 check:
33 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
34
35+testprogs:
36+ KERNEL_DIR=$(KERNEL_DIR) make -C tests testprogs
37+
38 CPOPTS =
39 ifneq ($(SHOW_TYPES),)
40 CPOPTS += --show-types
41Index: git/tests/Makefile
42===================================================================
43--- git.orig/tests/Makefile
44+++ git/tests/Makefile
45@@ -23,6 +23,12 @@ bindir = $(execprefix)/bin
46
47 all: $(hostprogs)
48
49+install:
50+ install -d $(DESTDIR)/usr/bin/tests_cryptodev
51+ for bin in $(hostprogs); do \
52+ install -m 755 $${bin} $(DESTDIR)/usr/bin/tests_cryptodev/; \
53+ done
54+
55 check: $(hostprogs)
56 ./cipher
57 ./hmac
58@@ -38,6 +44,8 @@ install:
59 install -m 755 $$prog $(DESTDIR)/$(bindir); \
60 done
61
62+testprogs: $(hostprogs)
63+
64 clean:
65 rm -f *.o *~ $(hostprogs)
66
diff --git a/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch b/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
deleted file mode 100644
index 885b5823..00000000
--- a/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From 8a884f55bd1527baa82fab68c186ba546273860c Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sun, 6 Apr 2014 19:51:39 -0400
4Subject: [PATCH] Disable installing header file provided by another package
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7
8Upstream-Status: Inappropriate [ OE specific ]
9---
10 Makefile | 1 -
11 1 file changed, 1 deletion(-)
12
13diff --git a/Makefile b/Makefile
14index 5a080e0..bf02396 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -33,7 +33,6 @@ install: modules_install
18
19 modules_install:
20 $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
21- install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
22
23 clean:
24 $(MAKE) $(KERNEL_MAKE_OPTS) clean