summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch63
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb1
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch
new file mode 100644
index 00000000..5c53e8e5
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch
@@ -0,0 +1,63 @@
1From c247745faaf885fd3fa094198fc0ea288e295dbf Mon Sep 17 00:00:00 2001
2From: Thibault Saunier <tsaunier@igalia.com>
3Date: Fri, 13 Jul 2018 14:42:28 -0400
4Subject: [PATCH] opencv: Fix build for opencv >= 3.4.2
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9The `CV_RGB` macro is now in `imgproc.hpp`.
10
11Fixes:
12
13 ../subprojects/gst-plugins-bad/ext/opencv/gsthanddetect.cpp:497:40: error: ‘CV_RGB’ was not declared in this scope
14 cvCircle (img, center, radius, CV_RGB (0, 0, 200), 1, 8, 0);
15 ^~~~~~
16---
17 ext/opencv/MotionCells.cpp | 3 +++
18 ext/opencv/gsthanddetect.cpp | 3 +++
19 ext/opencv/gsttemplatematch.cpp | 3 +++
20 3 files changed, 9 insertions(+)
21
22diff --git a/ext/opencv/MotionCells.cpp b/ext/opencv/MotionCells.cpp
23index f85989e117..175ec901b2 100644
24--- a/ext/opencv/MotionCells.cpp
25+++ b/ext/opencv/MotionCells.cpp
26@@ -51,6 +51,9 @@
27
28 #include <errno.h>
29 #include "MotionCells.h"
30+#if (CV_MAJOR_VERSION >= 3)
31+#include <opencv2/imgproc.hpp>
32+#endif
33 #include <opencv2/imgproc/imgproc_c.h>
34
35 MotionCells::MotionCells ()
36diff --git a/ext/opencv/gsthanddetect.cpp b/ext/opencv/gsthanddetect.cpp
37index 60fd5be72b..47203fd0ea 100644
38--- a/ext/opencv/gsthanddetect.cpp
39+++ b/ext/opencv/gsthanddetect.cpp
40@@ -62,6 +62,9 @@
41
42 /* element header */
43 #include "gsthanddetect.h"
44+#if (CV_MAJOR_VERSION >= 3)
45+#include <opencv2/imgproc.hpp>
46+#endif
47 #include <opencv2/imgproc/imgproc_c.h>
48
49 GST_DEBUG_CATEGORY_STATIC (gst_handdetect_debug);
50diff --git a/ext/opencv/gsttemplatematch.cpp b/ext/opencv/gsttemplatematch.cpp
51index f39208dc28..ec0b56af88 100644
52--- a/ext/opencv/gsttemplatematch.cpp
53+++ b/ext/opencv/gsttemplatematch.cpp
54@@ -63,6 +63,9 @@
55
56 #include "../../gst-libs/gst/gst-i18n-plugin.h"
57 #include "gsttemplatematch.h"
58+#if (CV_MAJOR_VERSION >= 3)
59+#include <opencv2/imgproc.hpp>
60+#endif
61 #include <opencv2/imgproc/imgproc_c.h>
62
63 GST_DEBUG_CATEGORY_STATIC (gst_template_match_debug);
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
index 313d4da1..f35c825b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
@@ -23,6 +23,7 @@ SRC_URI = " \
23 ${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} \ 23 ${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} \
24 file://configure-allow-to-disable-libssh2.patch \ 24 file://configure-allow-to-disable-libssh2.patch \
25 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \ 25 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
26 file://0001-opencv-fix-build-for-opencv-3-4-2.patch \
26" 27"
27 28
28SRCREV = "07ad0bb676a16c2dffb0f0e415a873f0924cfdc0" 29SRCREV = "07ad0bb676a16c2dffb0f0e415a873f0924cfdc0"