diff options
-rw-r--r-- | conf/machine/include/qoriq-arm.inc | 3 | ||||
-rw-r--r-- | conf/machine/include/qoriq-base.inc | 3 | ||||
-rw-r--r-- | recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-linux_1.7.bb) | 6 | ||||
-rw-r--r-- | recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-module_1.7.bb) | 6 | ||||
-rw-r--r-- | recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-tests_1.7.bb) | 6 | ||||
-rw-r--r-- | recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc (renamed from recipes-kernel/cryptodev/cryptodev_1.7.inc) | 0 |
6 files changed, 21 insertions, 3 deletions
diff --git a/conf/machine/include/qoriq-arm.inc b/conf/machine/include/qoriq-arm.inc index 20a75945..ba6345cf 100644 --- a/conf/machine/include/qoriq-arm.inc +++ b/conf/machine/include/qoriq-arm.inc | |||
@@ -4,6 +4,9 @@ require conf/machine/include/soc-family.inc | |||
4 | PREFERRED_PROVIDER_u-boot_ls102xa ?= "u-boot-ls1" | 4 | PREFERRED_PROVIDER_u-boot_ls102xa ?= "u-boot-ls1" |
5 | PREFERRED_PROVIDER_virtual/bootloader_ls102xa ?= "u-boot-ls1" | 5 | PREFERRED_PROVIDER_virtual/bootloader_ls102xa ?= "u-boot-ls1" |
6 | PREFERRED_PROVIDER_virtual/kernel_ls102xa ?= "linux-ls1" | 6 | PREFERRED_PROVIDER_virtual/kernel_ls102xa ?= "linux-ls1" |
7 | PREFERRED_PROVIDER_cryptodev_ls102xa = "cryptodev-qoriq" | ||
8 | PREFERRED_PROVIDER_cryptodev-module_ls102xa = "cryptodev-qoriq-module" | ||
9 | PREFERRED_PROVIDER_cryptodev-tests_ls102xa = "cryptodev-qoriq-tests" | ||
7 | 10 | ||
8 | # Define the default image type | 11 | # Define the default image type |
9 | IMAGE_CLASSES ?= "image_types_uboot" | 12 | IMAGE_CLASSES ?= "image_types_uboot" |
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc index 25d22978..e5949fa4 100644 --- a/conf/machine/include/qoriq-base.inc +++ b/conf/machine/include/qoriq-base.inc | |||
@@ -4,6 +4,9 @@ require conf/machine/include/soc-family.inc | |||
4 | # providers | 4 | # providers |
5 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq" | 5 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq" |
6 | PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq" | 6 | PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq" |
7 | PREFERRED_PROVIDER_cryptodev = "cryptodev-qoriq" | ||
8 | PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module" | ||
9 | PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests" | ||
7 | 10 | ||
8 | # versions | 11 | # versions |
9 | PREFERRED_VERSION_qemu = "2.2.0+fsl" | 12 | PREFERRED_VERSION_qemu = "2.2.0+fsl" |
diff --git a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb index 92ccd717..a388b4c8 100644 --- a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb +++ b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb | |||
@@ -1,7 +1,9 @@ | |||
1 | require cryptodev_${PV}.inc | 1 | require cryptodev-qoriq_${PV}.inc |
2 | 2 | ||
3 | SUMMARY = "A /dev/crypto device driver header file" | 3 | SUMMARY = "A /dev/crypto device driver header file" |
4 | 4 | ||
5 | PROVIDES = "cryptodev-linux" | ||
6 | |||
5 | do_compile[noexec] = "1" | 7 | do_compile[noexec] = "1" |
6 | 8 | ||
7 | # Just install cryptodev.h which is the only header file needed to be exported | 9 | # Just install cryptodev.h which is the only header file needed to be exported |
@@ -10,3 +12,5 @@ do_install() { | |||
10 | } | 12 | } |
11 | 13 | ||
12 | ALLOW_EMPTY_${PN} = "1" | 14 | ALLOW_EMPTY_${PN} = "1" |
15 | |||
16 | COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)" | ||
diff --git a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb index e6b1f27c..df2e5464 100644 --- a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb +++ b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb | |||
@@ -1,10 +1,14 @@ | |||
1 | require cryptodev_${PV}.inc | 1 | require cryptodev-qoriq_${PV}.inc |
2 | 2 | ||
3 | SUMMARY = "A /dev/crypto device driver kernel module" | 3 | SUMMARY = "A /dev/crypto device driver kernel module" |
4 | 4 | ||
5 | PROVIDES = "cryptodev-module" | ||
6 | |||
5 | inherit module qoriq_build_64bit_kernel | 7 | inherit module qoriq_build_64bit_kernel |
6 | 8 | ||
7 | # Header file provided by a separate package | 9 | # Header file provided by a separate package |
8 | DEPENDS += "cryptodev-linux" | 10 | DEPENDS += "cryptodev-linux" |
9 | 11 | ||
10 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' | 12 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' |
13 | |||
14 | COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)" | ||
diff --git a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb index 128ccc99..dd0afecd 100644 --- a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb +++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb | |||
@@ -1,8 +1,10 @@ | |||
1 | require cryptodev_${PV}.inc | 1 | require cryptodev-qoriq_${PV}.inc |
2 | 2 | ||
3 | SUMMARY = "A test suite for /dev/crypto device driver" | 3 | SUMMARY = "A test suite for /dev/crypto device driver" |
4 | DEPENDS = "openssl" | 4 | DEPENDS = "openssl" |
5 | 5 | ||
6 | PROVIDES = "cryptodev-tests" | ||
7 | |||
6 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' | 8 | EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' |
7 | 9 | ||
8 | do_compile() { | 10 | do_compile() { |
@@ -15,3 +17,5 @@ do_install() { | |||
15 | 17 | ||
16 | FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug" | 18 | FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug" |
17 | FILES_${PN} = "${bindir}/tests_cryptodev/*" | 19 | FILES_${PN} = "${bindir}/tests_cryptodev/*" |
20 | |||
21 | COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)" | ||
diff --git a/recipes-kernel/cryptodev/cryptodev_1.7.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc index 6b65f729..6b65f729 100644 --- a/recipes-kernel/cryptodev/cryptodev_1.7.inc +++ b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc | |||