diff options
-rw-r--r-- | meta-fsl-ppc/classes/qoriq_build_64bit_kernel.bbclass | 18 | ||||
-rw-r--r-- | meta-fsl-ppc/conf/layer.conf | 1 |
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-fsl-ppc/classes/qoriq_build_64bit_kernel.bbclass b/meta-fsl-ppc/classes/qoriq_build_64bit_kernel.bbclass new file mode 100644 index 00000000..562afd14 --- /dev/null +++ b/meta-fsl-ppc/classes/qoriq_build_64bit_kernel.bbclass | |||
@@ -0,0 +1,18 @@ | |||
1 | inherit distro_features_check | ||
2 | REQUIRED_DISTRO_FEATURES_e6500 += "multiarch" | ||
3 | |||
4 | python () { | ||
5 | pkgarch = d.getVar("TUNE_PKGARCH", True) | ||
6 | if not "ppce6500" == pkgarch: | ||
7 | return | ||
8 | |||
9 | promote_kernel = d.getVar('BUILD_64BIT_KERNEL') | ||
10 | if promote_kernel == "1": | ||
11 | d.setVar('KERNEL_CC_append', ' -m64') | ||
12 | d.setVar('KERNEL_LD_append', ' -melf64ppc') | ||
13 | |||
14 | error_qa = d.getVar('ERROR_QA', True) | ||
15 | if 'arch' in error_qa: | ||
16 | d.setVar('ERROR_QA', error_qa.replace(' arch', '')) | ||
17 | } | ||
18 | |||
diff --git a/meta-fsl-ppc/conf/layer.conf b/meta-fsl-ppc/conf/layer.conf index 0f81db04..9c0a4125 100644 --- a/meta-fsl-ppc/conf/layer.conf +++ b/meta-fsl-ppc/conf/layer.conf | |||
@@ -3,6 +3,7 @@ BBPATH .= ":${LAYERDIR}" | |||
3 | 3 | ||
4 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*" | 4 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*" |
5 | BBFILES += "${LAYERDIR}/images/*.bb*" | 5 | BBFILES += "${LAYERDIR}/images/*.bb*" |
6 | BBFILES += "${LAYERDIR}/classes/*.bb*" | ||
6 | 7 | ||
7 | BBFILE_COLLECTIONS += "fsl-ppc" | 8 | BBFILE_COLLECTIONS += "fsl-ppc" |
8 | BBFILE_PATTERN_fsl-ppc = "^${LAYERDIR}/" | 9 | BBFILE_PATTERN_fsl-ppc = "^${LAYERDIR}/" |