summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb32
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb29
2 files changed, 29 insertions, 32 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb
deleted file mode 100644
index 3dcfcef8..00000000
--- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017, 2019 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6DEPENDS = "virtual/imxvpu"
7LICENSE = "Proprietary"
8SECTION = "multimedia"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d"
10
11# For backwards compatibility
12PROVIDES += "libfslvpuwrap"
13RREPLACES_${PN} = "libfslvpuwrap"
14RPROVIDES_${PN} = "libfslvpuwrap"
15RCONFLICTS_${PN} = "libfslvpuwrap"
16
17SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
18
19SRC_URI[md5sum] = "41515584410b9e9a75d0880b51af5d76"
20SRC_URI[sha256sum] = "b2a7297afc9c5e1caebc1f3b7b4755430f595241d283c61cd0a3ba13dcf5c82b"
21
22inherit fsl-eula-unpack autotools pkgconfig
23
24do_install_append() {
25 # FIXME: Drop examples for now
26 rm -r ${D}${datadir}
27}
28
29INSANE_SKIP_imx-vpuwrap = "file-rdeps"
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(imxvpu)"
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb
new file mode 100644
index 00000000..06f97b09
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb
@@ -0,0 +1,29 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright (C) 2017-2020 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
9
10DEPENDS = "virtual/imxvpu"
11DEPENDS_append_mx8mp = " imx-vpu-hantro-vc"
12
13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
14
15SRCBRANCH = "MM_04.05.05_2005_L5.4.24"
16SRCREV = "76225d8e15b2b72cd11ce073706473473e446294"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22do_install_append() {
23 # FIXME: Drop examples for now
24 rm -r ${D}${datadir}
25}
26
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29COMPATIBLE_MACHINE = "(imxvpu)"