summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-08-31 20:48:35 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-05 19:44:05 -0300
commit443f182f25b01c8dc137012f40df559b3b4ef7c8 (patch)
tree7dea9981789a62d7413d3db5722c84ed16edb21a
parentb9002e4ce93915a353eb72d73d8fa3f9a8a08190 (diff)
downloadmeta-freescale-443f182f25b01c8dc137012f40df559b3b4ef7c8.tar.gz
imx-vpuwrap: upgrade to 4.5.5
Starting from this version, imx-vpuwrap is provided in a separate GIT repository and no longer in archive. Following commits are added in this release (including command): $ git log --oneline --no-decorate 8a3f1b0..b683295 b683295 MA-17072 [VC8000E] Set AVC default profile/level ae24b72 MA-16984 update Android.bp to remove "imx_defaults" 1349ea2 MA-16873-4 Update vpu_wrapper path c1235d2 MA-16830-2 Fix memleak when free memory in wrapper f680b3c MMFMWK-8745 hantro: enable reorder config for hantro vpu 3685f06 MA-16717-3 add VPU_DEC_SKIP for CODEC_PIC_SKIPPED 35b43ea MA-16717-2 Add Config to reset codecdata flag 8c92057 MMFMWK-8742 Map decoders to timestamps ad0bc7f MMFMWK-8739 [8mp]Grecorder: Only one recorded ts file play well when set '-n 3' 6c306bc MMFMWK-8738 [8mp] Set right input buffer's Y,U,V physical address 1524207 MMFMWK-8736 Fix hantro decoder can't get fullrange flag of files encoded with vc8000e 19fe757 MA-16593 [evk_8mm] Fix video hang due to error frame 13459f7 MMFMWK-8733 Update EULA.txt for vpu_wrapper according to imx-release-info 35ea5e6 [configurea.ac] Update version to 4.5.5 for next release 94c38de MA-16435-1 Modify Android makefile 96e189f MMFMWK-8720 Replace docs/EULA.txt and add SRC file SCR-imx-vpuwrap.txt 341dc9b MMFMWK-8720 Simplify vpu wrapper bf6680e MMFMWK-8720 Sync vpu wrapper code with Android and change copyright 1e6bc61 MMFMWK-8720 fix vc8000e encoder can't work a61d115 MMFMWK-8722 Fix color abnormal issue of streaming feature f68972d MMFMWK-8722 [8mp] Fix bitrate getting smaller issue of VC8000E encoder e7b3992 MMFMWK-8718 Enable cropping for hantro encoder at preprocess stage 017ecf7 MMFMWK-8714 [8mp] Adjust parameters to get correct filesize with given bit rate. 95acceb MMFMWK-8595 seperate 845 and 865 rootfs 180d19f MMFMWK-8595 Enable VC8000E encoder for 865 6fb749b [configurea.ac] Update version to 4.5.4 for next release Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> Cc: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb32
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb29
2 files changed, 29 insertions, 32 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb
deleted file mode 100644
index 3dcfcef8..00000000
--- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.3.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017, 2019 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6DEPENDS = "virtual/imxvpu"
7LICENSE = "Proprietary"
8SECTION = "multimedia"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d"
10
11# For backwards compatibility
12PROVIDES += "libfslvpuwrap"
13RREPLACES_${PN} = "libfslvpuwrap"
14RPROVIDES_${PN} = "libfslvpuwrap"
15RCONFLICTS_${PN} = "libfslvpuwrap"
16
17SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
18
19SRC_URI[md5sum] = "41515584410b9e9a75d0880b51af5d76"
20SRC_URI[sha256sum] = "b2a7297afc9c5e1caebc1f3b7b4755430f595241d283c61cd0a3ba13dcf5c82b"
21
22inherit fsl-eula-unpack autotools pkgconfig
23
24do_install_append() {
25 # FIXME: Drop examples for now
26 rm -r ${D}${datadir}
27}
28
29INSANE_SKIP_imx-vpuwrap = "file-rdeps"
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(imxvpu)"
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb
new file mode 100644
index 00000000..06f97b09
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.5.5.bb
@@ -0,0 +1,29 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright (C) 2017-2020 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
9
10DEPENDS = "virtual/imxvpu"
11DEPENDS_append_mx8mp = " imx-vpu-hantro-vc"
12
13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
14
15SRCBRANCH = "MM_04.05.05_2005_L5.4.24"
16SRCREV = "76225d8e15b2b72cd11ce073706473473e446294"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22do_install_append() {
23 # FIXME: Drop examples for now
24 rm -r ${D}${datadir}
25}
26
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29COMPATIBLE_MACHINE = "(imxvpu)"