summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index e8a9b9a3..36702a00 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -18,19 +18,19 @@ python () {
18PACKAGECONFIG_append_use-mainline-bsp = " gallium" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium"
19PACKAGECONFIG_append_use-mainline-bsp_armv7a = " etnaviv freedreno kmsro vc4" 19PACKAGECONFIG_append_use-mainline-bsp_armv7a = " etnaviv freedreno kmsro vc4"
20PACKAGECONFIG_append_use-mainline-bsp_armv7ve = " etnaviv freedreno kmsro vc4" 20PACKAGECONFIG_append_use-mainline-bsp_armv7ve = " etnaviv freedreno kmsro vc4"
21PACKAGECONFIG_append_use-mainline-bsp_mx8 = " etnaviv kmsro vc4"
21 22
22# Define the osmesa block in PACKAGECONFIG for target, this block is 23USE_OSMESA_ONLY ?= "no"
23# not defined in the master recipe, effectively causing the osmesa
24# feature to be disabled and -Dosmesa=none set.
25PACKAGECONFIG_append_mx8 = " osmesa"
26 24
27# Solve 'Problem encountered: OSMesa classic requires dri (classic) swrast.' 25# Etnaviv support state for i.MX8 is unknown, therefore only enable OSMesa and
28# by defining the dri swrast for mx8mm machine 26# disable Gallium for now. If you still want to enable Etnaviv, just set
29DRIDRIVERS_append_mx8 = "swrast" 27# USE_OSMESA_ONLY_mx8 = "no" in your bbappend.
28USE_OSMESA_ONLY_mx8 ?= "yes"
30 29
31# Solve 'ERROR: Problem encountered: Only one swrast provider can be built' 30# Enable OSMesa which also requires dri (classic) swrast
32# by excluding gallium support, dri is used together with 'classic' mesa backend. 31PACKAGECONFIG_append = " ${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', ' osmesa', '', d)}"
33PACKAGECONFIG_remove_mx8 = "gallium" 32PACKAGECONFIG_remove = " ${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', 'gallium', '', d)}"
33DRIDRIVERS_append = "${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', 'swrast', '', d)}"
34 34
35BACKEND = \ 35BACKEND = \
36 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 36 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \