summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/atf/atf_git.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
index 2f8a38a0..0f70d730 100644
--- a/recipes-bsp/atf/atf_git.bb
+++ b/recipes-bsp/atf/atf_git.bb
@@ -13,7 +13,7 @@ do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy"
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1" 15SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
16SRCREV = "7e34aebe658c7c3439d2d68b0ce6b9776e8e6996" 16SRCREV = "17f94e4315e81e3d1b22d863d9614d724e8273dc"
17 17
18SRC_URI += "file://0001-fix-fiptool-build-error.patch \ 18SRC_URI += "file://0001-fix-fiptool-build-error.patch \
19 file://0001-Makefile-add-CC-gcc.patch \ 19 file://0001-Makefile-add-CC-gcc.patch \
@@ -47,6 +47,7 @@ chassistype_ls1012ardb = "ls104x_1012"
47chassistype_ls1012afrwy = "ls104x_1012" 47chassistype_ls1012afrwy = "ls104x_1012"
48chassistype_ls1043ardb = "ls104x_1012" 48chassistype_ls1043ardb = "ls104x_1012"
49chassistype_ls1046ardb = "ls104x_1012" 49chassistype_ls1046ardb = "ls104x_1012"
50chassistype_ls1046afrwy = "ls104x_1012"
50 51
51ddrphyopt ?= "" 52ddrphyopt ?= ""
52ddrphyopt_lx2160ardb = "fip_ddr_sec" 53ddrphyopt_lx2160ardb = "fip_ddr_sec"
@@ -97,6 +98,10 @@ do_compile() {
97 ;; 98 ;;
98 qspi) 99 qspi)
99 rcwimg="${RCWQSPI}${rcwtemp}.bin" 100 rcwimg="${RCWQSPI}${rcwtemp}.bin"
101 uefiboot="${UEFI_QSPIBOOT}"
102 if [ "${BUILD_SECURE}" = "true" ] && [ ${MACHINE} = ls1046ardb ]; then
103 rcwimg="RR_FFSSPPPH_1133_5559/rcw_1600_qspiboot_sben.bin"
104 fi
100 ;; 105 ;;
101 sd) 106 sd)
102 rcwimg="${RCWSD}${rcwtemp}.bin" 107 rcwimg="${RCWSD}${rcwtemp}.bin"
@@ -165,6 +170,9 @@ do_install() {
165 fi 170 fi
166 fi 171 fi
167 chown -R root:root ${D} 172 chown -R root:root ${D}
173 if [ -f "${S}/fip_ddr_sec.bin" ]; then
174 cp -r ${S}/fip_ddr_sec.bin ${D}/boot/atf/fip_ddr_sec.bin
175 fi
168} 176}
169 177
170do_deploy() { 178do_deploy() {
@@ -195,6 +203,9 @@ do_deploy() {
195 cp -r ${S}/fuse_fip_512mb.bin ${D}/boot/atf/fuse_fip_512mb${secext}.bin 203 cp -r ${S}/fuse_fip_512mb.bin ${D}/boot/atf/fuse_fip_512mb${secext}.bin
196 fi 204 fi
197 fi 205 fi
206 if [ -f "${S}/fip_ddr_sec.bin" ]; then
207 cp -r ${D}/boot/atf/fip_ddr_sec.bin ${DEPLOYDIR}/atf/fip_ddr_sec.bin
208 fi
198} 209}
199addtask deploy after do_install 210addtask deploy after do_install
200FILES_${PN} += "/boot" 211FILES_${PN} += "/boot"