summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/cst/cst_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/cst/cst_git.bb
index 17fc9b38..a57db6c4 100644
--- a/recipes-devtools/cst/cst_git.bb
+++ b/recipes-devtools/cst/cst_git.bb
@@ -4,9 +4,12 @@ LICENSE = "BSD"
4 4
5LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff"
6 6
7DEPENDS += "openssl" 7DEPENDS += "openssl cst-native"
8RDEPENDS_${PN} = "bash" 8RDEPENDS_${PN} = "bash"
9 9
10GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys"
11GENKEYS_class-native = "./gen_keys"
12
10inherit kernel-arch 13inherit kernel-arch
11 14
12# specify the non default keys pair for secure boot if needed 15# specify the non default keys pair for secure boot if needed
@@ -25,13 +28,13 @@ PARALLEL_MAKE = ""
25 28
26do_install () { 29do_install () {
27 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir} 30 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
31
28 if [ -n "${SECURE_PRI_KEY}" ]; then 32 if [ -n "${SECURE_PRI_KEY}" ]; then
29 cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri 33 cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri
30 cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub 34 cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub
31 elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then 35 elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then
32 cd ${D}/${bindir}/cst && ./gen_keys 1024 36 cd ${D}/${bindir}/cst && ${GENKEYS} 1024
33 fi 37 fi
34
35} 38}
36 39
37FILES_${PN}-dbg += "${bindir}/cst/.debug" 40FILES_${PN}-dbg += "${bindir}/cst/.debug"