summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/imx-boot-container.bbclass2
-rw-r--r--classes/uuu_bootloader_tag.bbclass24
-rw-r--r--conf/machine/include/imx-base.inc4
-rw-r--r--dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb2
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb40
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb18
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2024.07.bb5
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2024.04.bb13
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb8
-rw-r--r--recipes-multimedia/tinycompress/tinycompress_1.1.6.bb2
-rw-r--r--wic/imx-imx-boot-bootpart.wks.in2
-rw-r--r--wic/imx-imx-boot.wks.in2
-rw-r--r--wic/imx-uboot-bootpart.wks.in2
-rw-r--r--wic/imx-uboot-spl-bootpart.wks.in2
-rw-r--r--wic/imx-uboot-spl.wks.in2
-rw-r--r--wic/imx-uboot.wks2
16 files changed, 46 insertions, 84 deletions
diff --git a/classes/imx-boot-container.bbclass b/classes/imx-boot-container.bbclass
index 8ba32cac..b0d3dc1f 100644
--- a/classes/imx-boot-container.bbclass
+++ b/classes/imx-boot-container.bbclass
@@ -96,7 +96,7 @@ do_deploy:append() {
96 if [ ! -f "${DEPLOYDIR}/imx-boot" ]; then 96 if [ ! -f "${DEPLOYDIR}/imx-boot" ]; then
97 ln -sf flash.bin-${MACHINE}-${type} flash.bin 97 ln -sf flash.bin-${MACHINE}-${type} flash.bin
98 ln -sf flash.bin-${MACHINE}-${type} imx-boot 98 ln -sf flash.bin-${MACHINE}-${type} imx-boot
99 99 ln -sf flash.bin.tagged imx-boot.tagged
100 else 100 else
101 bbwarn "Use custom wks.in for $UBOOT_CONFIG = $type" 101 bbwarn "Use custom wks.in for $UBOOT_CONFIG = $type"
102 fi 102 fi
diff --git a/classes/uuu_bootloader_tag.bbclass b/classes/uuu_bootloader_tag.bbclass
index 87745660..b41d22a9 100644
--- a/classes/uuu_bootloader_tag.bbclass
+++ b/classes/uuu_bootloader_tag.bbclass
@@ -1,12 +1,20 @@
1# Append a tag to the bootloader image used in the SD card image. The tag 1# Create a tagged boot partition file for the SD card image file. The tag
2# contains the size of the bootloader image so UUU can easily find the end of 2# contains the size of the boot partition image so UUU can easily find
3# the bootloader in the SD card image. 3# the end of it in the SD card image file.
4#
5# IMPORTANT: The tagged boot partition file should never be used directly with
6# UUU, as it can cause UUU to hang.
7
8UUU_BOOTLOADER = "${UBOOT_BINARY}"
9UUU_BOOTLOADER:mx8-generic-bsp = "${@d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '0' and 'imx-boot' or 'flash.bin'}"
10UUU_BOOTLOADER:mx9-generic-bsp = "${@d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '0' and 'imx-boot' or 'flash.bin'}"
11
4do_deploy:append() { 12do_deploy:append() {
5 if [ "${UUU_BOOTLOADER}" != "" ]; then 13 if [ "${UUU_BOOTLOADER}" != "" ]; then
6 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED} 14 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} \
7 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_UNTAGGED} 15 ${DEPLOYDIR}/${UUU_BOOTLOADER}.tagged
8 ln -sf ${UUU_BOOTLOADER_TAGGED} ${DEPLOYDIR}/${UUU_BOOTLOADER} 16 stat -L -cUUUBURNXXOEUZX7+A-XY5601QQWWZ%sEND \
9 stat -L -cUUUBURNXXOEUZX7+A-XY5601QQWWZ%sEND ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED} \ 17 ${DEPLOYDIR}/${UUU_BOOTLOADER}.tagged \
10 >> ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED} 18 >> ${DEPLOYDIR}/${UUU_BOOTLOADER}.tagged
11 fi 19 fi
12} 20}
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 43d62756..b127cee4 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -653,9 +653,9 @@ WKS_FILE_DEPENDS:append:imx-generic-bsp:mx9-generic-bsp = " \
653 ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '0', 'imx-boot', '')} \ 653 ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '0', 'imx-boot', '')} \
654" 654"
655 655
656SOC_DEFAULT_WKS_FILE ?= "imx-uboot-bootpart.wks.in" 656SOC_DEFAULT_WKS_FILE ?= "imx-uboot-bootpart.wks.in"
657SOC_DEFAULT_WKS_FILE:mx8-generic-bsp ?= "imx-imx-boot-bootpart.wks.in"
658SOC_DEFAULT_WKS_FILE:mxs-generic-bsp ?= "imx-uboot-mxs-bootpart.wks.in" 657SOC_DEFAULT_WKS_FILE:mxs-generic-bsp ?= "imx-uboot-mxs-bootpart.wks.in"
658SOC_DEFAULT_WKS_FILE:mx8-generic-bsp ?= "imx-imx-boot-bootpart.wks.in"
659SOC_DEFAULT_WKS_FILE:mx9-generic-bsp ?= "imx-imx-boot-bootpart.wks.in" 659SOC_DEFAULT_WKS_FILE:mx9-generic-bsp ?= "imx-imx-boot-bootpart.wks.in"
660 660
661WKS_FILE ?= "${SOC_DEFAULT_WKS_FILE}" 661WKS_FILE ?= "${SOC_DEFAULT_WKS_FILE}"
diff --git a/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb b/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb
index a853a803..b10bd869 100644
--- a/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb
+++ b/dynamic-layers/arm-toolchain/recipes-bsp/imx-oei/imx-oei_1.0.0.bb
@@ -15,6 +15,8 @@ S = "${WORKDIR}/git"
15 15
16inherit deploy 16inherit deploy
17 17
18PACKAGE_ARCH = "${MACHINE_ARCH}"
19
18OEI_CONFIGS ?= "UNDEFINED" 20OEI_CONFIGS ?= "UNDEFINED"
19OEI_CORE ?= "UNDEFINED" 21OEI_CORE ?= "UNDEFINED"
20OEI_SOC ?= "UNDEFINED" 22OEI_SOC ?= "UNDEFINED"
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb
deleted file mode 100644
index 0e0ebc6e..00000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "i.MX code signing tool"
2DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library"
3SECTION = "cst"
4LICENSE = "BSD-3-Clause & Apache-2.0"
5
6LIC_FILES_CHKSUM = "\
7 file://LICENSE.bsd3;md5=14aba05f9fa6c25527297c8aac95fcf6 \
8 file://LICENSE.hidapi;md5=e0ea014f523f64f0adb13409055ee59e \
9 file://LICENSE.openssl;md5=3441526b1df5cc01d812c7dfc218cea6 \
10"
11
12DEPENDS = "byacc-native flex-native openssl"
13
14# debian: 3.4.0+dfsg-2
15DEBIAN_PGK_NAME = "imx-code-signing-tool"
16DEBIAN_PGK_VERSION = "${PV}+dfsg"
17
18SRC_URI = "\
19 ${DEBIAN_MIRROR}/main/i/${DEBIAN_PGK_NAME}/${DEBIAN_PGK_NAME}_${DEBIAN_PGK_VERSION}.orig.tar.xz \
20"
21
22SRC_URI[sha256sum] = "52ee3cee3bc500a42095f73c4584e223b4b9d2dfc1cd3e5df965c5952eba8c8d"
23
24S = "${WORKDIR}/${DEBIAN_PGK_NAME}-${DEBIAN_PGK_VERSION}"
25
26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"'
27
28do_compile() {
29 oe_runmake -C code/obj.linux64 OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}"
30 oe_runmake -C add-ons/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
31}
32
33do_install () {
34 install -d ${D}${bindir}
35 install -m 755 ${S}/code/obj.linux64/cst ${D}${bindir}/
36 install -m 755 ${S}/code/obj.linux64/srktool ${D}${bindir}
37 install -m 755 ${S}/add-ons/hab_csf_parser/csf_parser ${D}${bindir}
38}
39
40BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index 83b9ad78..3c027044 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -19,14 +19,10 @@ DEPENDS += " \
19DEPENDS += "xxd-native" 19DEPENDS += "xxd-native"
20DEPENDS:append:mx8m-generic-bsp = " u-boot-mkimage-native dtc-native" 20DEPENDS:append:mx8m-generic-bsp = " u-boot-mkimage-native dtc-native"
21DEPENDS:append:mx93-generic-bsp = " u-boot-mkimage-native dtc-native" 21DEPENDS:append:mx93-generic-bsp = " u-boot-mkimage-native dtc-native"
22BOOT_NAME = "imx-boot"
23PROVIDES = "${BOOT_NAME}"
24 22
25inherit deploy uuu_bootloader_tag 23inherit deploy uuu_bootloader_tag
26 24
27UUU_BOOTLOADER = "${BOOT_NAME}" 25UUU_BOOTLOADER = "imx-boot"
28UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged"
29UUU_BOOTLOADER_UNTAGGED = "${BOOT_NAME}-untagged"
30 26
31# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build 27# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build
32CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" 28CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}"
@@ -222,7 +218,7 @@ do_compile() {
222 UBOOT_DTB_NAME_EXTRA="${dtb_name}" 218 UBOOT_DTB_NAME_EXTRA="${dtb_name}"
223 fi 219 fi
224 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}" 220 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}"
225 BOOT_CONFIG_MACHINE_EXTRA="${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 221 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
226 222
227 for target in ${IMXBOOT_TARGETS}; do 223 for target in ${IMXBOOT_TARGETS}; do
228 compile_${SOC_FAMILY} 224 compile_${SOC_FAMILY}
@@ -273,7 +269,7 @@ do_install () {
273 bbnote "UBOOT_CONFIG = $type" 269 bbnote "UBOOT_CONFIG = $type"
274 270
275 UBOOT_CONFIG_EXTRA="$type" 271 UBOOT_CONFIG_EXTRA="$type"
276 BOOT_CONFIG_MACHINE_EXTRA="${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 272 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
277 273
278 for target in ${IMXBOOT_TARGETS}; do 274 for target in ${IMXBOOT_TARGETS}; do
279 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${D}/boot/ 275 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${D}/boot/
@@ -380,7 +376,7 @@ do_deploy() {
380 for type in ${UBOOT_CONFIG}; do 376 for type in ${UBOOT_CONFIG}; do
381 UBOOT_CONFIG_EXTRA="$type" 377 UBOOT_CONFIG_EXTRA="$type"
382 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}" 378 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}"
383 BOOT_CONFIG_MACHINE_EXTRA="${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 379 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
384 380
385 if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} ] ; then 381 if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} ] ; then
386 install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \ 382 install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \
@@ -399,9 +395,9 @@ do_deploy() {
399 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${DEPLOYDIR} 395 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${DEPLOYDIR}
400 done 396 done
401 397
402 # The first UBOOT_CONFIG listed will be the ${BOOT_NAME} binary 398 # The first UBOOT_CONFIG listed will be the imx-boot binary
403 if [ ! -f "${DEPLOYDIR}/${UUU_BOOTLOADER}" ]; then 399 if [ ! -f "${DEPLOYDIR}/imx-boot" ]; then
404 ln -sf ${BOOT_CONFIG_MACHINE_EXTRA}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/${BOOT_NAME} 400 ln -sf ${BOOT_CONFIG_MACHINE_EXTRA}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/imx-boot
405 else 401 else
406 bbwarn "Use custom wks.in for $UBOOT_CONFIG = $type" 402 bbwarn "Use custom wks.in for $UBOOT_CONFIG = $type"
407 fi 403 fi
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2024.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2024.07.bb
index eba8876a..4dc69821 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2024.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2024.07.bb
@@ -6,8 +6,6 @@ order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \ 6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming." 7version, or because it is not applicable for upstreaming."
8 8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native" 9DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native"
12 10
13PROVIDES += "u-boot u-boot-mfgtool" 11PROVIDES += "u-boot u-boot-mfgtool"
@@ -21,5 +19,8 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
21 HOSTLDFLAGS="${BUILD_LDFLAGS}" \ 19 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
22 HOSTSTRIP=true' 20 HOSTSTRIP=true'
23 21
22inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
23inherit uuu_bootloader_tag
24
24PACKAGE_ARCH = "${MACHINE_ARCH}" 25PACKAGE_ARCH = "${MACHINE_ARCH}"
25COMPATIBLE_MACHINE = "(imx-generic-bsp)" 26COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2024.04.bb b/recipes-bsp/u-boot/u-boot-imx_2024.04.bb
index 3d03c834..29d83527 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2024.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2024.04.bb
@@ -9,15 +9,10 @@ PROVIDES += "u-boot u-boot-mfgtool"
9 9
10inherit uuu_bootloader_tag 10inherit uuu_bootloader_tag
11 11
12UUU_BOOTLOADER = "" 12# The UUU tag goes on the boot partition. For 8+, the boot partition image
13UUU_BOOTLOADER:mx6-generic-bsp = "${UBOOT_BINARY}" 13# is imx-boot, so disable UUU-tagging here
14UUU_BOOTLOADER:mx7-generic-bsp = "${UBOOT_BINARY}" 14UUU_BOOTLOADER:mx8-generic-bsp = ""
15UUU_BOOTLOADER_TAGGED = "" 15UUU_BOOTLOADER:mx9-generic-bsp = ""
16UUU_BOOTLOADER_TAGGED:mx6-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
18UUU_BOOTLOADER_UNTAGGED = ""
19UUU_BOOTLOADER_UNTAGGED:mx6-generic-bsp = "u-boot-untagged.${UBOOT_SUFFIX}"
20UUU_BOOTLOADER_UNTAGGED:mx7-generic-bsp = "u-boot-untagged.${UBOOT_SUFFIX}"
21 16
22do_deploy:append:mx8m-generic-bsp() { 17do_deploy:append:mx8m-generic-bsp() {
23 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 18 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
index 314ebf48..4810ca11 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v6.6.28 31# tag: v6.6.23
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
@@ -51,16 +51,16 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
51 51
52require linux-imx.inc 52require linux-imx.inc
53 53
54KBRANCH = "6.6-1.0.x-imx" 54KBRANCH = "6.6-2.0.x-imx"
55SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 55SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
56SRCREV = "13ed4e83694299049a3d4449fdb61471292ef19b" 56SRCREV = "dd280fd310dd5fabbff7393175ee9d7a6aea6b34"
57 57
58# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 58# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
59# required by kernel-yocto.bbclass. 59# required by kernel-yocto.bbclass.
60# 60#
61# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 61# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
62# should be updated once patchlevel is merged. 62# should be updated once patchlevel is merged.
63LINUX_VERSION = "6.6.28" 63LINUX_VERSION = "6.6.23"
64 64
65KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 65KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
66KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 66KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"
diff --git a/recipes-multimedia/tinycompress/tinycompress_1.1.6.bb b/recipes-multimedia/tinycompress/tinycompress_1.1.6.bb
index 803c38df..5cad5ba6 100644
--- a/recipes-multimedia/tinycompress/tinycompress_1.1.6.bb
+++ b/recipes-multimedia/tinycompress/tinycompress_1.1.6.bb
@@ -3,7 +3,7 @@ LICENSE = "LGPL-2.1-only | BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=cf9105c1a2d4405cbe04bbe3367373a0" 3LIC_FILES_CHKSUM = "file://COPYING;md5=cf9105c1a2d4405cbe04bbe3367373a0"
4DEPENDS = "alsa-lib" 4DEPENDS = "alsa-lib"
5 5
6SRC_URI = "git://git.alsa-project.org/tinycompress.git;protocol=git;branch=master \ 6SRC_URI = "git://git.alsa-project.org/http/tinycompress.git;protocol=https;branch=master \
7 file://0001-tinycompress-Add-id3-decoding.patch \ 7 file://0001-tinycompress-Add-id3-decoding.patch \
8 file://0002-cplay-Support-wave-file.patch \ 8 file://0002-cplay-Support-wave-file.patch \
9 file://0003-cplay-Add-pause-feature.patch \ 9 file://0003-cplay-Add-pause-feature.patch \
diff --git a/wic/imx-imx-boot-bootpart.wks.in b/wic/imx-imx-boot-bootpart.wks.in
index b50364d1..20af7a6a 100644
--- a/wic/imx-imx-boot-bootpart.wks.in
+++ b/wic/imx-imx-boot-bootpart.wks.in
@@ -13,7 +13,7 @@
13# 0 | 8MiB 72MiB 72MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 13# 0 | 8MiB 72MiB 72MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
14# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual 14# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual
15# 15#
16part u-boot --source rawcopy --sourceparams="file=imx-boot" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK} 16part u-boot --source rawcopy --sourceparams="file=imx-boot.tagged" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK}
17part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 8192 --size 64 17part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 8192 --size 64
18part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192 18part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192
19 19
diff --git a/wic/imx-imx-boot.wks.in b/wic/imx-imx-boot.wks.in
index 8e78b5e3..fdb41180 100644
--- a/wic/imx-imx-boot.wks.in
+++ b/wic/imx-imx-boot.wks.in
@@ -13,7 +13,7 @@
13# 0 | 8MiB 8MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 13# 0 | 8MiB 8MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
14# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual 14# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual
15# 15#
16part u-boot --source rawcopy --sourceparams="file=imx-boot" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK} 16part u-boot --source rawcopy --sourceparams="file=imx-boot.tagged" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK}
17part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192 17part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192
18 18
19bootloader --ptable msdos 19bootloader --ptable msdos
diff --git a/wic/imx-uboot-bootpart.wks.in b/wic/imx-uboot-bootpart.wks.in
index 8fe019c0..4959d02d 100644
--- a/wic/imx-uboot-bootpart.wks.in
+++ b/wic/imx-uboot-bootpart.wks.in
@@ -12,7 +12,7 @@
12# | | | | 12# | | | |
13# 0 1kiB 4MiB 16MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 13# 0 1kiB 4MiB 16MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
14# 14#
15part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}" --ondisk mmcblk --no-table --align 1 15part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}.tagged" --ondisk mmcblk --no-table --align 1
16part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 4096 --size 16 16part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 4096 --size 16
17part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096 17part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096
18 18
diff --git a/wic/imx-uboot-spl-bootpart.wks.in b/wic/imx-uboot-spl-bootpart.wks.in
index 8062c51e..be0f0fe0 100644
--- a/wic/imx-uboot-spl-bootpart.wks.in
+++ b/wic/imx-uboot-spl-bootpart.wks.in
@@ -13,7 +13,7 @@
13# 0 1kiB 69kiB 4MiB 16MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 13# 0 1kiB 69kiB 4MiB 16MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
14# 14#
15part SPL --source rawcopy --sourceparams="file=SPL" --ondisk mmcblk --no-table --align 1 15part SPL --source rawcopy --sourceparams="file=SPL" --ondisk mmcblk --no-table --align 1
16part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}" --ondisk mmcblk --no-table --align 69 16part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}.tagged" --ondisk mmcblk --no-table --align 69
17part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 4096 --size 16 17part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 4096 --size 16
18part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096 18part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096
19 19
diff --git a/wic/imx-uboot-spl.wks.in b/wic/imx-uboot-spl.wks.in
index db2f89dd..c6c9aaa2 100644
--- a/wic/imx-uboot-spl.wks.in
+++ b/wic/imx-uboot-spl.wks.in
@@ -13,7 +13,7 @@
13# 0 1kiB 69kiB 4MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 13# 0 1kiB 69kiB 4MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
14# 14#
15part SPL --source rawcopy --sourceparams="file=SPL" --ondisk mmcblk --no-table --align 1 15part SPL --source rawcopy --sourceparams="file=SPL" --ondisk mmcblk --no-table --align 1
16part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}" --ondisk mmcblk --no-table --align 69 16part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}.tagged" --ondisk mmcblk --no-table --align 69
17part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096 17part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096
18 18
19bootloader --ptable msdos 19bootloader --ptable msdos
diff --git a/wic/imx-uboot.wks b/wic/imx-uboot.wks
index 60870c34..cde24798 100644
--- a/wic/imx-uboot.wks
+++ b/wic/imx-uboot.wks
@@ -12,7 +12,7 @@
12# | | | | 12# | | | |
13# 0 1kiB 4MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) 13# 0 1kiB 4MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
14# 14#
15part u-boot --source rawcopy --sourceparams="file=u-boot.imx" --ondisk mmcblk --no-table --align 1 15part u-boot --source rawcopy --sourceparams="file=${UBOOT_BINARY}.tagged" --ondisk mmcblk --no-table --align 1
16part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096 16part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096
17 17
18bootloader --ptable msdos 18bootloader --ptable msdos