summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-16 12:38:52 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commite933d4b9df470210cbbe331c2a91394ac681b15b (patch)
tree52b122ec413211c52a435618bb42c1afeac28f03 /recipes-security
parent85f2b61f46ac5b8c5ac3c7e747c803891b8ec9b7 (diff)
downloadmeta-freescale-e933d4b9df470210cbbe331c2a91394ac681b15b.tar.gz
optee-os: Use tee-raw.bin binary
During the optee-os compilation, the gen_tee_bin.py script generates a tee-raw.bin that is more space efficient and could replace the tee.bin binary manually generated in the optee-os recipe by objcpy. This patch greatly reduces the size of tee.bin. On 64 bits platforms, we observe a size descrease of ~68%, and on 32 bits platforms, a size decrease of ~45%. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-os_3.15.0.imx.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
index defcf63d..bdc00bc3 100644
--- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2017-2020 NXP 1# Copyright (C) 2017-2021 NXP
2 2
3SUMMARY = "OPTEE OS" 3SUMMARY = "OPTEE OS"
4DESCRIPTION = "OPTEE OS" 4DESCRIPTION = "OPTEE OS"
@@ -62,7 +62,7 @@ CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
62 62
63do_deploy () { 63do_deploy () {
64 install -d ${DEPLOYDIR} 64 install -d ${DEPLOYDIR}
65 ${TARGET_PREFIX}objcopy -O binary ${B}/core/tee.elf ${DEPLOYDIR}/tee.${PLATFORM_FLAVOR}.bin 65 cp ${B}/core/tee-raw.bin ${DEPLOYDIR}/tee.${PLATFORM_FLAVOR}.bin
66 ln -sf tee.${PLATFORM_FLAVOR}.bin ${DEPLOYDIR}/tee.bin 66 ln -sf tee.${PLATFORM_FLAVOR}.bin ${DEPLOYDIR}/tee.bin
67 67
68 if [ "${OPTEE_ARCH}" != "arm64" ]; then 68 if [ "${OPTEE_ARCH}" != "arm64" ]; then