summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-31 17:39:35 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-03-31 19:37:58 -0500
commitd93b387a8740bc5f6e61dac13888e9cc0f1cefa2 (patch)
tree5111741914b7fcb87aac225fa886c757e782456b /recipes-security
parent65398605b9f412ac851c945f4cbe36a81b899a8f (diff)
downloadmeta-freescale-d93b387a8740bc5f6e61dac13888e9cc0f1cefa2.tar.gz
mx8dx: Normalize MACHINEOVERRIDES implementation
The imx8dx-mek machine is similar to imx8qxp-mek and so the mx8qxp override was included in the MACHINEOVERRIDES hierarchy. This is non-standard, and the rework of the SOC overrides didn't handle it properly, leading to a build break: ``` Log data follows: | DEBUG: Executing shell function do_compile | NOTE: 8QX boot binary build | cp: failed to access '/home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin': Not a directory | WARNING: /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636:179 exit 1 from 'cp /home/aquino/src/ossystems/oel-platform/build/tmp/deploy/images/imx8dx-mek/imx-boot$ tools/scfw_tcm.bin /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin' | WARNING: Backtrace (BB generated script): | #1: compile_mx8x, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 179 | #2: do_compile, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 151 | #3: main, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 189 ERROR: Task (/home/aquino/src/ossystems/oel-platform/sources/meta-freescale/recipes-bsp/imx-mkimage/imx-boot_1.0.bb:do_compile) failed with exit code '1' ``` Fix the problem by removing mx8qxp from the mx8dx hierarchy and adapting existing mx8qxp overrides appropriately. Fixes: #1027 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-os_3.15.0.imx.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
index e3eea2b4..3fca3dbf 100644
--- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
@@ -31,14 +31,14 @@ PLATFORM_FLAVOR:imx6ul = "mx6ulevk"
31PLATFORM_FLAVOR:imx6ull = "mx6ullevk" 31PLATFORM_FLAVOR:imx6ull = "mx6ullevk"
32PLATFORM_FLAVOR:imx6ull = "mx6ullevk" 32PLATFORM_FLAVOR:imx6ull = "mx6ullevk"
33PLATFORM_FLAVOR:imx6ulz = "mx6ulzevk" 33PLATFORM_FLAVOR:imx6ulz = "mx6ulzevk"
34PLATFORM_FLAVOR:mx8mq-nxp-bsp = "mx8mqevk" 34PLATFORM_FLAVOR:mx8mq-nxp-bsp = "mx8mqevk"
35PLATFORM_FLAVOR:mx8mm-nxp-bsp = "mx8mmevk" 35PLATFORM_FLAVOR:mx8mm-nxp-bsp = "mx8mmevk"
36PLATFORM_FLAVOR:mx8mn-nxp-bsp = "mx8mnevk" 36PLATFORM_FLAVOR:mx8mn-nxp-bsp = "mx8mnevk"
37PLATFORM_FLAVOR:mx8mp-nxp-bsp = "mx8mpevk" 37PLATFORM_FLAVOR:mx8mp-nxp-bsp = "mx8mpevk"
38PLATFORM_FLAVOR:mx8qm-nxp-bsp = "mx8qmmek" 38PLATFORM_FLAVOR:mx8qm-nxp-bsp = "mx8qmmek"
39PLATFORM_FLAVOR:mx8qxp-nxp-bsp = "mx8qxpmek" 39PLATFORM_FLAVOR:mx8qxp-nxp-bsp = "mx8qxpmek"
40PLATFORM_FLAVOR:mx8dx-nxp-bsp = "mx8dxmek" 40PLATFORM_FLAVOR:mx8dx-nxp-bsp = "mx8dxmek"
41PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk" 41PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk"
42 42
43OPTEE_ARCH ?= "arm32" 43OPTEE_ARCH ?= "arm32"
44OPTEE_ARCH:armv7a = "arm32" 44OPTEE_ARCH:armv7a = "arm32"