summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@foundries.io>2023-07-26 13:42:57 +0300
committerOleksandr Suvorov <oleksandr.suvorov@foundries.io>2023-07-28 16:39:03 +0300
commitab83ab04f51dbdb289376769f59bb0c8f60429ea (patch)
tree0957706970b31246cbd8ea675edb64d400d1e6ef /recipes-security
parent4ae12b59af79ade0293da21b24433e79bd80d09c (diff)
downloadmeta-freescale-ab83ab04f51dbdb289376769f59bb0c8f60429ea.tar.gz
optee-client: Upgrade to lf-6.1.22-2.0.0 (3.21)
Upgrade optee-client to be aligned with NXP BSP LF6.1.22_2.0.0. Backport changes from meta-arm/optee-client.inc. Relevant changes: - 8533e0e travis: remove the .travis.yml file - 0fc6ef7 tee-supplicant: fix leak when load plugin failed - dde6306 libteeacl: use realloc() instead of reallocarray() - 462b954 Add -Wunsafe-loop-optimizations only for gcc - 2096542 Makefile: use GNU standards for directory variables - dd2d39b libteeacl: Move uuid-dev checking in libteec makefile - 1056b40 cmake: define boolean switch CFG_WERROR with option() - bbdf665 libteeacl: condition libteeacl with WITH_TEEACL - fba9950 ci: add GitHub Actions script and Docker files - fc67c27 Add pkgconfig file for libteec - d448e8b Allow cross-compile pkg-config - d26d885 libckteec: Add RSA AES key wrap serialization - cb3842c tee-supplicant: Synchronize file operations for secure storage Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@foundries.io>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-client_3.19.0.imx.bb4
-rw-r--r--recipes-security/optee-imx/optee-client_3.21.0.imx.bb7
-rw-r--r--recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch33
-rw-r--r--recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch28
4 files changed, 7 insertions, 65 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.19.0.imx.bb b/recipes-security/optee-imx/optee-client_3.19.0.imx.bb
deleted file mode 100644
index 102b3ce9..00000000
--- a/recipes-security/optee-imx/optee-client_3.19.0.imx.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1require optee-client-fslc-imx.inc
2
3SRCBRANCH = "lf-6.1.1_1.0.0"
4SRCREV = "01231b7a7ce03cdf9d3f48e7baa0bce17aac28f7"
diff --git a/recipes-security/optee-imx/optee-client_3.21.0.imx.bb b/recipes-security/optee-imx/optee-client_3.21.0.imx.bb
new file mode 100644
index 00000000..5d508911
--- /dev/null
+++ b/recipes-security/optee-imx/optee-client_3.21.0.imx.bb
@@ -0,0 +1,7 @@
1require optee-client-fslc-imx.inc
2
3SRCBRANCH = "lf-6.1.22_2.0.0"
4SRCREV = "8533e0e6329840ee96cf81b6453f257204227e6c"
5
6DEPENDS += "util-linux"
7EXTRA_OEMAKE += "PKG_CONFIG=pkg-config"
diff --git a/recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch b/recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
deleted file mode 100644
index c07d0482..00000000
--- a/recipes-security/optee-imx/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 528aeb42652a3159c1bfd51d6c1442c3ff27b84c Mon Sep 17 00:00:00 2001
2From: Ross Burton <ross.burton@arm.com>
3Date: Tue, 26 May 2020 14:38:02 -0500
4Subject: [PATCH] allow setting sysroot for libgcc lookup
5
6Explicitly pass the new variable LIBGCC_LOCATE_CFLAGS variable when searching
7for the compiler libraries as there's no easy way to reliably pass --sysroot
8otherwise.
9
10Upstream-Status: Pending [https://github.com/OP-TEE/optee_os/issues/4188]
11Signed-off-by: Ross Burton <ross.burton@arm.com>
12
13---
14 mk/gcc.mk | 6 +++---
15 1 file changed, 3 insertions(+), 3 deletions(-)
16
17--- a/mk/gcc.mk
18+++ b/mk/gcc.mk
19@@ -13,11 +13,11 @@ nostdinc$(sm) := -nostdinc -isystem $(sh
20 -print-file-name=include 2> /dev/null)
21
22 # Get location of libgcc from gcc
23-libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \
24+libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \
25 -print-libgcc-file-name 2> /dev/null)
26-libstdc++$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
27+libstdc++$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
28 -print-file-name=libstdc++.a 2> /dev/null)
29-libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
30+libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
31 -print-file-name=libgcc_eh.a 2> /dev/null)
32
33 # Define these to something to discover accidental use
diff --git a/recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch b/recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch
deleted file mode 100644
index dc6d5517..00000000
--- a/recipes-security/optee-imx/optee-os/0007-allow-setting-sysroot-for-clang.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From db9e44af75c7cfd3316cab15aaa387383df3e57e Mon Sep 17 00:00:00 2001
2From: Brett Warren <brett.warren@arm.com>
3Date: Wed, 23 Sep 2020 09:27:34 +0100
4Subject: [PATCH] optee: enable clang support
5
6When compiling with clang, the LIBGCC_LOCATE_CFLAG variable used
7to provide a sysroot wasn't included, which results in not locating
8compiler-rt. This is mitigated by including the variable as ammended.
9
10Upstream-Status: Pending
11ChangeId: 8ba69a4b2eb8ebaa047cb266c9aa6c2c3da45701
12Signed-off-by: Brett Warren <brett.warren@arm.com>
13
14---
15 mk/clang.mk | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18--- a/mk/clang.mk
19+++ b/mk/clang.mk
20@@ -30,7 +30,7 @@ comp-cflags-warns-clang := -Wno-language
21
22 # Note, use the compiler runtime library (libclang_rt.builtins.*.a) instead of
23 # libgcc for clang
24-libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \
25+libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \
26 -rtlib=compiler-rt -print-libgcc-file-name 2> /dev/null)
27
28 # Core ASLR relies on the executable being ready to run from its preferred load