summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-12 17:33:29 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-05-12 17:37:45 -0500
commita11a0895a4b16ba5ae31693feff379e3de646045 (patch)
tree787cf590f3a70875bfdcbf570be62b026df91af4 /recipes-security
parentf51ff30cb96c31866fca8ca89bb17511b45efe35 (diff)
downloadmeta-freescale-a11a0895a4b16ba5ae31693feff379e3de646045.tar.gz
optee-test: Upgrade to NXP 5.15.5-1.0.0
- Fix hard-coded /usr with exec_prefix variable - Parallel make works, remove work around Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-test_3.15.0.imx.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
index 1d6de243..a44454a7 100644
--- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
@@ -8,14 +8,14 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8 8
9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl" 9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl"
10 10
11SRCBRANCH = "lf-5.10.72_2.2.0" 11SRCBRANCH = "lf-5.15.5_1.0.0"
12 12
13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}" 13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build" 16B = "${WORKDIR}/build"
17 17
18SRCREV = "4d81b964a72e89a62d04187b3f055d8346b383c9" 18SRCREV = "e9d8bf6ee121d6686e6e409c727caee76496bb86"
19 19
20inherit python3native features_check 20inherit python3native features_check
21 21
@@ -34,7 +34,7 @@ CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
34EXTRA_OEMAKE = " \ 34EXTRA_OEMAKE = " \
35 TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ 35 TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \
36 ARCH=${OPTEE_ARCH} \ 36 ARCH=${OPTEE_ARCH} \
37 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}/usr \ 37 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \
38 CROSS_COMPILE_HOST=${HOST_PREFIX} \ 38 CROSS_COMPILE_HOST=${HOST_PREFIX} \
39 CROSS_COMPILE_TA=${HOST_PREFIX} \ 39 CROSS_COMPILE_TA=${HOST_PREFIX} \
40 CROSS_COMPILE=${HOST_PREFIX} \ 40 CROSS_COMPILE=${HOST_PREFIX} \
@@ -42,11 +42,7 @@ EXTRA_OEMAKE = " \
42" 42"
43 43
44do_compile() { 44do_compile() {
45 cd ${S} 45 oe_runmake all
46 # Top level makefile doesn't seem to handle parallel make gracefully
47 oe_runmake xtest
48 oe_runmake ta
49 oe_runmake test_plugin
50} 46}
51do_compile[cleandirs] = "${B}" 47do_compile[cleandirs] = "${B}"
52 48