summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-05 23:10:40 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-05 23:49:00 -0800
commit86680b12d44ffe2831244a2f7f7dcaaa1a1440c5 (patch)
treec477e3be24caefb6c1390a9c9051299e2674b064 /recipes-security
parentc16f2b7613ac29b73f0fc8bcc123346bf988f900 (diff)
downloadmeta-freescale-86680b12d44ffe2831244a2f7f7dcaaa1a1440c5.tar.gz
optee-os,optee-test: Use gcc compiler
It does not compile with clang, all work to get it compiling with clang has gone into 3.18+ ( see meta-arm ) until imx version revs up to 3.18 lets use gcc always to build it Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-os_3.17.0.imx.bb2
-rw-r--r--recipes-security/optee-imx/optee-test_3.17.0.imx.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.17.0.imx.bb b/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
index b6452ef0..f759e40c 100644
--- a/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
@@ -111,3 +111,5 @@ RDEPENDS:${PN}-dev += "${PN}-staticdev"
111 111
112PACKAGE_ARCH = "${MACHINE_ARCH}" 112PACKAGE_ARCH = "${MACHINE_ARCH}"
113COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 113COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
114
115TOOLCHAIN = "gcc"
diff --git a/recipes-security/optee-imx/optee-test_3.17.0.imx.bb b/recipes-security/optee-imx/optee-test_3.17.0.imx.bb
index da56eed7..e1b831f1 100644
--- a/recipes-security/optee-imx/optee-test_3.17.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.17.0.imx.bb
@@ -58,3 +58,5 @@ FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/ ${libdir}/tee-supplicant/plu
58RDEPENDS:${PN} = "optee-os" 58RDEPENDS:${PN} = "optee-os"
59 59
60COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 60COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
61
62TOOLCHAIN = "gcc"