summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-16 13:01:04 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commit81b0be2a35572af796126b4b532e1610f2bffc71 (patch)
tree49eb8b2ca274eb2d769306eae90afbb61a408044 /recipes-security
parentf20a803504f049d4504b480a79adf49b18c7f149 (diff)
downloadmeta-freescale-81b0be2a35572af796126b4b532e1610f2bffc71.tar.gz
optee-os: Install embedded TAs
optee-os has some embedded TAs like AVB or PKCS11 that must be installed in the filesystem. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-os_3.15.0.imx.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
index e3b8eff4..58b238a7 100644
--- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
@@ -82,12 +82,18 @@ do_install () {
82 for f in ${B}/export-ta_${OPTEE_ARCH}/*; do 82 for f in ${B}/export-ta_${OPTEE_ARCH}/*; do
83 cp -aR $f ${D}${includedir}/optee/export-user_ta_${OPTEE_ARCH}/ 83 cp -aR $f ${D}${includedir}/optee/export-user_ta_${OPTEE_ARCH}/
84 done 84 done
85
86 # Install embedded TAs
87 install -d ${D}${nonarch_base_libdir}/optee_armtz
88 find ${B}/ta -name '*.ta' | while read name; do
89 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/
90 done
85} 91}
86 92
87addtask deploy after do_compile before do_install 93addtask deploy after do_compile before do_install
88 94
89 95
90FILES:${PN} = "${nonarch_base_libdir}/firmware/" 96FILES:${PN} = "${nonarch_base_libdir}/firmware/ ${nonarch_base_libdir}/optee_armtz/"
91FILES:${PN}-staticdev = "/usr/include/optee/" 97FILES:${PN}-staticdev = "/usr/include/optee/"
92RDEPENDS:${PN}-dev += "${PN}-staticdev" 98RDEPENDS:${PN}-dev += "${PN}-staticdev"
93 99