summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorStefano Viola <stefano.viola@toradex.com>2023-05-24 18:49:44 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2023-05-25 14:37:24 -0300
commit617d50bebb3bec40c58efd256df63fa2e9fa69cb (patch)
tree16b9ff42ebd793d8f374071ae5009a3d3bc530f7 /recipes-security
parent01d9ba2bfca7935a6ed54eb81ca76ec9ee56ed0d (diff)
downloadmeta-freescale-617d50bebb3bec40c58efd256df63fa2e9fa69cb.tar.gz
keyctl-caam: add keyctl-caam recipe from meta-imx
this recipe comes from meta-imx. keyctl-caam is a tool useful to implement use cases like encrypted storage using CAAM secure keys as described in the NXP Application note AN12714. Signed-off-by: Stefano Viola <stefano.viola@toradex.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/swm/keyctl-caam_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-security/swm/keyctl-caam_git.bb b/recipes-security/swm/keyctl-caam_git.bb
new file mode 100644
index 00000000..25a5f656
--- /dev/null
+++ b/recipes-security/swm/keyctl-caam_git.bb
@@ -0,0 +1,23 @@
1# Copyright 2020-2022 NXP
2
3SUMMARY = "NXP i.MX CAAM Keyctl"
4DESCRIPTION = "NXP i.MX keyctl tool to manage CAAM Keys"
5SECTION = "base"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8636bd68fc00cc6a3809b7b58b45f982"
8
9SRCBRANCH = "master"
10SRC_URI = "git://github.com/nxp-imx/keyctl_caam.git;protocol=https;branch=${SRCBRANCH}"
11
12SRCREV = "81dc06cdb9c4d0d4ba10459d85af9a8603774948"
13
14S = "${WORKDIR}/git"
15
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_install () {
19 oe_runmake DESTDIR=${D} install
20}
21
22COMPATIBLE_MACHINE = "(imx-generic-bsp)"
23