summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2020-04-08 21:24:52 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-17 12:48:54 -0300
commit3fd85f63dc0894a7f0caa62146b99cd7f400e671 (patch)
treecabb403114ff92cc5ed0f443208c006e1ec438fe /recipes-security
parent4ab569fb67b9499e4782071aec9ba92174184786 (diff)
downloadmeta-freescale-3fd85f63dc0894a7f0caa62146b99cd7f400e671.tar.gz
optee-test_3.2.0.imx: add patch to use python3, backported from v3.8.0
This avoids build errors such as optee-test/3.2.0.imx-r0/git/out/ta/crypt//mid_crt.c] Error 127 | /usr/bin/env: ‘python’: No such file or directory Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-test/0001-use-python3-instead-of-python.patch48
-rw-r--r--recipes-security/optee-imx/optee-test_3.2.0.imx.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test/0001-use-python3-instead-of-python.patch b/recipes-security/optee-imx/optee-test/0001-use-python3-instead-of-python.patch
new file mode 100644
index 00000000..20f190af
--- /dev/null
+++ b/recipes-security/optee-imx/optee-test/0001-use-python3-instead-of-python.patch
@@ -0,0 +1,48 @@
1From 6271160639002a2580d80b75b5397a96d56329f2 Mon Sep 17 00:00:00 2001
2From: Scott Branden <scott.branden@broadcom.com>
3Date: Fri, 27 Dec 2019 12:54:28 -0800
4Subject: [PATCH] use python3 instead of python
5
6use python3 instead of python as python2 is EOL January 2020.
7
8Signed-off-by: Scott Branden <scott.branden@broadcom.com>
9Reviewed-by: Jerome Forissier <jerome@forissier.org>
10Tested-by: Jerome Forissier <jerome@forissier.org> (QEMU, CFG_GCM_NIST_VECTORS=y)
11Upstream-Status: Backport from v3.8.0
12---
13 scripts/file_to_c.py | 4 ++--
14 scripts/rsp_to_gcm_test.py | 2 +-
15 2 files changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/scripts/file_to_c.py b/scripts/file_to_c.py
18index ae16f52..b4ce2a2 100755
19--- a/scripts/file_to_c.py
20+++ b/scripts/file_to_c.py
21@@ -1,4 +1,4 @@
22-#!/usr/bin/env python
23+#!/usr/bin/env python3
24 # SPDX-License-Identifier: BSD-2-Clause
25 #
26 # Copyright (c) 2018, Linaro Limited
27@@ -29,7 +29,7 @@ def main():
28
29 f.write("const uint8_t " + args.name + "[] = {\n")
30 i = 0
31- for x in array.array("B", inf.read()):
32+ for x in array.array("B", map(ord, (inf.read()))):
33 f.write("0x" + '{0:02x}'.format(x) + ",")
34 i = i + 1
35 if i % 8 == 0:
36diff --git a/scripts/rsp_to_gcm_test.py b/scripts/rsp_to_gcm_test.py
37index 0543541..e4418be 100755
38--- a/scripts/rsp_to_gcm_test.py
39+++ b/scripts/rsp_to_gcm_test.py
40@@ -1,4 +1,4 @@
41-#!/usr/bin/env python
42+#!/usr/bin/env python3
43
44 modes = {'encrypt': 0, 'decrypt': 1}
45
46--
472.7.4
48
diff --git a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
index 03cb2b57..dc92511a 100644
--- a/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.2.0.imx.bb
@@ -19,6 +19,7 @@ SRC_URI = "${OPTEE_TEST_SRC};branch=${SRCBRANCH} \
19 file://0004-build-ignore-declaration-after-statement-warnings.patch \ 19 file://0004-build-ignore-declaration-after-statement-warnings.patch \
20 file://0005-benchmark_1000-fix-compilation-against-musl-uint.patch \ 20 file://0005-benchmark_1000-fix-compilation-against-musl-uint.patch \
21 file://0006-regression_8100-use-null-terminated-strings-with-fil.patch \ 21 file://0006-regression_8100-use-null-terminated-strings-with-fil.patch \
22 file://0001-use-python3-instead-of-python.patch \
22" 23"
23 24
24S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"