summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-10-31 15:55:06 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-10-31 15:55:06 -0500
commit282e2619f00fb7b1a006fa09627fd4d4a74ba107 (patch)
tree461a176236b2c80d55d721960312b41fd63445da /recipes-security
parent2e0a904ddd1f05dc0b907c86dc8168a2f817cc26 (diff)
downloadmeta-freescale-282e2619f00fb7b1a006fa09627fd4d4a74ba107.tar.gz
optee-os: Update lf-5.15.32_2.0.0 -> lf-5.15.52_2.1.0
Changes: ``` 9e86c8b6b LFOPTEE-169 imx_ele: use get_info command to get the soc revision 74f662cf4 LFOPTEE-169 imx_ele: check ELE TRNG status before getting random numbers f74752516 LFOPTEE-196 imx_ele: make the difference ELE_VERSION_BASELINE and ELE_VERSION_HSM c3f658958 LFOPTEE-172 core: imx_ele: cache the die ID 96dc392d7 scripts: nxp_build: remove ls1012afrwy platform 31125f8be core: plat-ls: remove OP-TEE support for LS1012A-FRWY platform bb2173330 core: plat-ls: correct expression CFG_NUM_THREADS ?= CFG_TEE_CORE_NB_CORE 2166caac3 core: plat-ls: set CFG_NUM_THREADS ?= 2 for LS1012ARDB 21059100b drivers: caam: increase the minimum entropy delay the imx6sx a3d4b52b0 drivers: imx: dcp: disable the use of UNIQUE KEY after HUK generation 9162aecfd drivers: imx: dcp: clear OTP_KEY bit for unique key selection d5144e4a9 drivers: imx: dcp: workaround DCP errata 051292 d61caabeb core: pta: return error code when failing to deserialize saved key 198e47860 core: pta: attestation: fix buffer size for generated key c1e398428 drivers: pm: remove file with license issue 2a725689b LF-6067 drivers: caam: map the CAAM registers with the CAAM_SIZE value 639dfbc1f LF-6067 core: ls: add CAAM_SIZE values for LS platforms 42a864fd1 LF-6067 core: imx: add CAAM_SIZE values for i.MX platforms 6ebec0d2a LFOPTEE-159 drivers: imx_snvs: re-work security state for imx8m platforms 588403cd7 LFOPTEE-158 scripts: add imx93evk platform 18e11b984 LFOPTEE-158 core: imx: add support imx93evk platform 813af1a3c LFOPTEE-158 core: imx: add imx93 SoC ID aea51ea0b LFOPTEE-158 core: imx: add imx93 registers ede0b7183 LFOPTEE-158 core: imx: simplify the error macro message 742bee71c drivers: imx_snvs: fix the is_otpmk_valid() logic 6bb686a04 drivers: imx_snvs: fix SNVS register read operation 111482cfe LFOPTEE-146 drivers: imx_ele: add CRC computation and check for ELE calls dd227c6c5 LFOPTEE-146 drivers: imx_ele: reformat code for consistency 907c2f86f LFOPTEE-146 drivers: imx_ele: ask the ELE for the unique device ID b421225d9 LFOPTEE-146 drivers: remove imx_ele_mu_init() function 09e9d1b62 LFOPTEE-146 drivers: imx_mu: increase the message limit size b6c4a695b core: plat-ls: correct CAAM JR interrupt numbers 13ce5deb6 LFOPTEE-147 core: imx: fix uninitialized return value e5ea58a7b LFOPTEE-141 drivers: imx_mu: Disable foreign exception when sending message to MU ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-os_3.17.0.imx.bb30
1 files changed, 19 insertions, 11 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.17.0.imx.bb b/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
index 93e0ff6e..b6452ef0 100644
--- a/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.17.0.imx.bb
@@ -8,15 +8,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c1f21c4f72f372ef38a5a4aee55ec173"
8 8
9DEPENDS = "python3-cryptography-native python3-pyelftools-native u-boot-mkimage-native" 9DEPENDS = "python3-cryptography-native python3-pyelftools-native u-boot-mkimage-native"
10 10
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https;branch=${SRCBRANCH}" 11SRC_URI = "git://github.com/nxp-imx/imx-optee-os.git;protocol=https;branch=${SRCBRANCH}"
12SRCBRANCH = "lf-5.15.32_2.0.0" 12SRCBRANCH = "lf-5.15.52_2.1.0"
13SRCREV = "984996422c25c99ebfc5194c1bb393028605bb0c" 13SRCREV = "9e86c8b6b102efa09ada451d0383ea3d11f8fad6"
14 14
15SRC_URI:append = " \ 15SRC_URI:append = " \
16 file://0008-no-warn-rwx-segments.patch \ 16 file://0008-no-warn-rwx-segments.patch \
17 " 17 "
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20B = "${WORKDIR}/build"
20 21
21inherit deploy python3native autotools features_check 22inherit deploy python3native autotools features_check
22 23
@@ -60,20 +61,29 @@ EXTRA_OEMAKE = " \
60 -C ${S} O=${B} \ 61 -C ${S} O=${B} \
61" 62"
62 63
63LDFLAGS = "" 64LDFLAGS[unexport] = "1"
64CFLAGS += "--sysroot=${STAGING_DIR_HOST}" 65CFLAGS += "--sysroot=${STAGING_DIR_HOST}"
65CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" 66CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
66 67
68do_configure[noexec] = "1"
69
70do_compile:arm () {
71 oe_runmake all uTee
72}
73
74do_compile:aarch64 () {
75 oe_runmake all
76}
77do_compile[cleandirs] = "${B}"
78
67do_deploy () { 79do_deploy () {
68 install -d ${DEPLOYDIR} 80 install -d ${DEPLOYDIR}
69 cp ${B}/core/tee-raw.bin ${DEPLOYDIR}/tee.${PLATFORM_FLAVOR}.bin 81 cp ${B}/core/tee-raw.bin ${DEPLOYDIR}/tee.${PLATFORM_FLAVOR}.bin
70 ln -sf tee.${PLATFORM_FLAVOR}.bin ${DEPLOYDIR}/tee.bin 82 ln -sf tee.${PLATFORM_FLAVOR}.bin ${DEPLOYDIR}/tee.bin
83}
71 84
72 if [ "${OPTEE_ARCH}" != "arm64" ]; then 85do_deploy:append:arm () {
73 IMX_LOAD_ADDR=`${TARGET_PREFIX}readelf -h ${B}/core/tee.elf | grep "Entry point address" | awk '{print $4}'` 86 cp ${B}/core/uTee ${DEPLOYDIR}/uTee-${OPTEE_BIN_EXT}
74 uboot-mkimage -A arm -O linux -C none -a ${IMX_LOAD_ADDR} -e ${IMX_LOAD_ADDR} \
75 -d ${DEPLOYDIR}/tee.${PLATFORM_FLAVOR}.bin ${DEPLOYDIR}/uTee-${OPTEE_BIN_EXT}
76 fi
77} 87}
78 88
79do_install () { 89do_install () {
@@ -82,7 +92,6 @@ do_install () {
82 92
83 # Install the TA devkit 93 # Install the TA devkit
84 install -d ${D}${includedir}/optee/export-user_ta_${OPTEE_ARCH}/ 94 install -d ${D}${includedir}/optee/export-user_ta_${OPTEE_ARCH}/
85
86 for f in ${B}/export-ta_${OPTEE_ARCH}/*; do 95 for f in ${B}/export-ta_${OPTEE_ARCH}/*; do
87 cp -aR $f ${D}${includedir}/optee/export-user_ta_${OPTEE_ARCH}/ 96 cp -aR $f ${D}${includedir}/optee/export-user_ta_${OPTEE_ARCH}/
88 done 97 done
@@ -96,7 +105,6 @@ do_install () {
96 105
97addtask deploy after do_compile before do_install 106addtask deploy after do_compile before do_install
98 107
99
100FILES:${PN} = "${nonarch_base_libdir}/firmware/ ${nonarch_base_libdir}/optee_armtz/" 108FILES:${PN} = "${nonarch_base_libdir}/firmware/ ${nonarch_base_libdir}/optee_armtz/"
101FILES:${PN}-staticdev = "${includedir}/optee/" 109FILES:${PN}-staticdev = "${includedir}/optee/"
102RDEPENDS:${PN}-dev += "${PN}-staticdev" 110RDEPENDS:${PN}-dev += "${PN}-staticdev"