summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-30 17:09:53 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 09:58:34 -0200
commit1cc4930cf29a394926ac48ca5db846326a2b123e (patch)
treed0b6b518702926c077ab698db00685a1ab876072 /recipes-security/optee
parent47f959f4b664fc3d0ca66c1bd1f32f4a33eceb55 (diff)
downloadmeta-freescale-1cc4930cf29a394926ac48ca5db846326a2b123e.tar.gz
optee-client: add recipes
*include the following changes: 73b4e49 - tee-supplicant: REE fs open file with O_SYNC flag 075c56e - tee_supplicant: add register memory feature 27888d7 - tee_client_api: register user memory f761a27 - tee-supplicant: move TEEC_LOAD_PATH to Makefile 48107e5 - tee_client_api: support calling libteec from cplusplus 32d9b77 - rpi3: fix unsupported exclusive access issue 0efaf6b - libteec/Makefile: create relative links to shared library instead of absolute ones 44c0d30 - Makefile: preserve links to libraries during make copy_export 5883a75 - libteec: benchmark cleanup e5ba7e8 - tee-supplicant: Report error on short buffer when loading TA 5db6c2d - Fix incorrect share memory size 48aed6e - Storage: Added CFG_TEE_FS_PARENT_PATH config option 1358c3f - Replace file permission symbolic values by octal numbers 63106fb - OP-TEE Benchmark 326001c - tee-supplicant: FS: remove unused legacy RPC functions d6a3291 - Remove leftovers of SQL FS 5de013f - supplicant: use public rpc command ids f8a4086 - supplicant: define/describe reserved Ids for supplicant commands a47e334 - client api: fix ULONG_MAX dependency 9faeb1b - tee_client_api: Correct max shared memory size define 4d5cf67 - tee-supplicant: correct block device path for android 403c9a1 - Remove SQL-FS 0b7aa7d - Android.mk: fix CFG_TEE_CLIENT_LOG_FILE checking 1df4046 - ree_fs_new_opendir(): ignore empty directory d507b84 - tee_supplicant_android.mk: Add missing configs for sockets ea42194 - tee-supplicant: fix variable is used unitialized error 79309c4 - Use the mode also in open_wrapper f79c74f - tee-supplicant: Add support for TCP/UDP iSocket interface 52e6ca1 - tee-supplicant: spawn threads as needed 5229afd - tee-supplicant: support asynchronous supplicant requests 5477e9e - tee-supplicant: Update TEEC_TEST_LOAD_PATH for Android 7f16107 - ree fs rpc: open with best-effort allowing RO data fs 3b4c507 - Add support for TA profiling (gprof) a1df073 - Rename optee_msg_fs.h to optee_msg_supplicant.h 1aaf6dc - tee-supplicant: disable warnings only for sql_fs.c 3656576 - Add backward compatibility with older TA UUID format 1d5cc96 - Allow O to be an absolute path ce5fefe - Format UUID strings correctly Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security/optee')
-rw-r--r--recipes-security/optee/optee-client.bb26
-rw-r--r--recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch67
2 files changed, 93 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-client.bb b/recipes-security/optee/optee-client.bb
new file mode 100644
index 00000000..b811e600
--- /dev/null
+++ b/recipes-security/optee/optee-client.bb
@@ -0,0 +1,26 @@
1SUMMARY = "OPTEE Client"
2HOMEPAGE = "https://github.com/qoriq-open-source/optee_client"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6
7inherit pythonnative systemd
8
9SRC_URI = "git://github.com/qoriq-open-source/optee_client.git;nobranch=1 \
10 file://0001-Respect-LDFLAGS-set-from-OE-build.patch \
11"
12S = "${WORKDIR}/git"
13
14SRCREV = "73b4e490a8ed0b4a7714818e80998b9d8a7da958"
15
16do_install() {
17 oe_runmake install
18
19 install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant
20
21 install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
22 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
23 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
24
25 cp -a ${S}/out/export/include ${D}/usr/
26}
diff --git a/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch b/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch
new file mode 100644
index 00000000..8dd6c7a9
--- /dev/null
+++ b/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch
@@ -0,0 +1,67 @@
1From 73cb675c16bd63ee0e760a4067ffda4b050d19fa Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 15 Jun 2017 17:20:35 -0700
4Subject: [PATCH] Respect LDFLAGS set from OE build
5
6* Unify LFLAGS/LDFLAGS variable names (only tee-supplicant was using LDFLAGS).
7* Fixes:
8 ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/bin/tee-supplicant'
9 No GNU_HASH in the elf binary: 'optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/packages-split/optee-client/usr/lib/libteec.so.1.0' [ldflags]
10 ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
11 ERROR: optee-client-2.4.0+gitAUTOINC+1df4046bd7-r0 do_package_qa: Function failed: do_package_qa
12 ERROR: Logfile of failure stored in: optee-client/2.4.0+gitAUTOINC+1df4046bd7-r0/temp/log.do_package_qa.31246
13
14Upstream-Status: Pending
15Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
16
17---
18 libteec/Makefile | 2 +-
19 tee-supplicant/Makefile | 8 ++++----
20 2 files changed, 5 insertions(+), 5 deletions(-)
21
22diff --git a/libteec/Makefile b/libteec/Makefile
23index 568a2cd..a406237 100644
24--- a/libteec/Makefile
25+++ b/libteec/Makefile
26@@ -36,7 +36,7 @@ ifeq ($(CFG_TEE_BENCHMARK),y)
27 TEEC_CFLAGS += -DCFG_TEE_BENCHMARK
28 endif
29
30-TEEC_LFLAGS := -lpthread
31+TEEC_LFLAGS := $(LDFLAGS) -lpthread
32 TEEC_LIBRARY := $(OUT_DIR)/$(LIB_MAJ_MIN)
33
34 libteec: $(TEEC_LIBRARY)
35diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
36index 737d39a..4b423fb 100644
37--- a/tee-supplicant/Makefile
38+++ b/tee-supplicant/Makefile
39@@ -55,21 +55,21 @@ ifeq ($(CFG_TA_TEST_PATH),y)
40 TEES_CFLAGS += -DCFG_TA_TEST_PATH=1
41 endif
42 TEES_FILE := $(OUT_DIR)/$(PACKAGE_NAME)
43-TEES_LDFLAGS := -L$(OUT_DIR)/../libteec -lteec
44+TEES_LFLAGS := $(LDFLAGS) -L$(OUT_DIR)/../libteec -lteec
45
46 ifeq ($(CFG_TA_GPROF_SUPPORT),y)
47 TEES_CFLAGS += -DCFG_TA_GPROF_SUPPORT
48 endif
49
50-TEES_LDFLAGS += -lpthread
51+TEES_LFLAGS += -lpthread
52 # Needed to get clock_gettime() for for glibc versions before 2.17
53-TEES_LDFLAGS += -lrt
54+TEES_LFLAGS += -lrt
55
56 tee-supplicant: $(TEES_FILE)
57
58 $(TEES_FILE): $(TEES_OBJS)
59 @echo " LINK $@"
60- $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS)
61+ $(VPREFIX)$(CC) -o $@ $+ $(TEES_LFLAGS)
62 @echo ""
63
64 $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c
65--
662.15.0.rc2
67