summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee/optee-os-qoriq_git.bb
diff options
context:
space:
mode:
authorC.R. Guo <chunrong.guo@nxp.com>2018-03-07 16:45:45 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-03-15 09:50:54 -0300
commitfe25ab0a190680d05bb3e3c5f509274d0f89d722 (patch)
tree4a37976eede2b18913ab132ebe691603400ad846 /recipes-security/optee/optee-os-qoriq_git.bb
parente0518234f9ac3e46755e931c341646cfd9cb6ae2 (diff)
downloadmeta-freescale-fe25ab0a190680d05bb3e3c5f509274d0f89d722.tar.gz
optee-os: Rename optee-os -> optee-os-qoriq
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-security/optee/optee-os-qoriq_git.bb')
-rw-r--r--recipes-security/optee/optee-os-qoriq_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-os-qoriq_git.bb b/recipes-security/optee/optee-os-qoriq_git.bb
new file mode 100644
index 00000000..21b467ef
--- /dev/null
+++ b/recipes-security/optee/optee-os-qoriq_git.bb
@@ -0,0 +1,67 @@
1SUMMARY = "OP-TEE Trusted OS"
2DESCRIPTION = "OPTEE OS"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
6
7DEPENDS = "python-pycrypto-native"
8
9inherit deploy pythonnative
10
11SRCREV = "4886ddbd44665589215df4ef010958cba55dc8ba"
12SRC_URI = "git://bitbucket.sw.nxp.com/scm/dash/optee_os.git;nobranch=1 \
13 file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
14 "
15
16S = "${WORKDIR}/git"
17
18OPTEEMACHINE ?= "${MACHINE}"
19
20EXTRA_OEMAKE = "PLATFORM=ls-${OPTEEMACHINE} CFG_ARM64_core=y \
21 ARCH=arm \
22 CROSS_COMPILE_core=${HOST_PREFIX} \
23 CROSS_COMPILE_ta_arm64=${HOST_PREFIX} \
24 NOWERROR=1 \
25 LDFLAGS= \
26 LIBGCC_LOCATE_CFLAGS=--sysroot=${STAGING_DIR_HOST} \
27 "
28
29OPTEE_ARCH_armv7a = "arm32"
30OPTEE_ARCH_aarch64 = "arm64"
31
32do_compile() {
33 unset LDFLAGS
34 oe_runmake all CFG_TEE_TA_LOG_LEVEL=0
35}
36
37do_install() {
38 #install core on boot directory
39 install -d ${D}/lib/firmware/
40
41 install -m 644 ${B}/out/arm-plat-ls/core/tee.elf ${D}/lib/firmware/tee_${MACHINE}.bin
42 #install TA devkit
43 install -d ${D}/usr/include/optee/export-user_ta/
44
45 for f in ${B}/out/arm-plat-ls/export-ta_${OPTEE_ARCH}/* ; do
46 cp -aR $f ${D}/usr/include/optee/export-user_ta/
47 done
48}
49
50PACKAGE_ARCH = "${MACHINE_ARCH}"
51
52do_deploy() {
53 install -d ${DEPLOYDIR}/optee
54 for f in ${D}/lib/firmware/*; do
55 install -m 644 $f ${DEPLOYDIR}/optee/tee_${MACHINE}.bin
56 done
57}
58
59addtask deploy before do_build after do_install
60
61FILES_${PN} = "/lib/firmware/"
62FILES_${PN}-dev = "/usr/include/optee"
63
64INSANE_SKIP_${PN}-dev = "staticdev"
65
66INHIBIT_PACKAGE_STRIP = "1"
67COMPATIBLE_MACHINE = "(ls1043ardb|ls1046ardb|ls1012ardb)"