summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-01-22 10:53:13 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-01-23 17:51:00 -0300
commit166d5ad78731bc9747baf41ca4bc6da91f884242 (patch)
tree268931fb71e17161b5087cb1dabbe9076e4bfb43 /recipes-security/optee-imx/optee-os_3.2.0.imx.bb
parent08063be6fa9a4f8541eca8e92e5f678ed3234fdd (diff)
downloadmeta-freescale-166d5ad78731bc9747baf41ca4bc6da91f884242.tar.gz
optee[-imx]: update recipes to use python3
Since Python2 is dropped in oe-core and classes are not available anymore, optee components should be updated to utilize python3. optee-os recipe received an additionl patch to re-target the Python version in the source tree to python3. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-os_3.2.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-os_3.2.0.imx.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
index c5328c9c..be07f0ef 100644
--- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
@@ -6,12 +6,16 @@ HOMEPAGE = "http://www.optee.org/"
6LICENSE = "BSD" 6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
8 8
9inherit deploy pythonnative autotools 9inherit deploy python3native autotools
10DEPENDS = "python-pycrypto-native u-boot-mkimage-native" 10DEPENDS = "python3-pycrypto-native u-boot-mkimage-native"
11 11
12SRCBRANCH = "imx_4.19.35_1.1.0" 12SRCBRANCH = "imx_4.19.35_1.1.0"
13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" 13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https"
14SRC_URI = "${OPTEE_OS_SRC};branch=${SRCBRANCH}" 14SRC_URI = "\
15 ${OPTEE_OS_SRC};branch=${SRCBRANCH} \
16 file://0001-scripts-update-scripts-to-use-python3.patch \
17"
18
15SRCREV = "6a22e6e8a2840b245808527679f3397b7e620b3c" 19SRCREV = "6a22e6e8a2840b245808527679f3397b7e620b3c"
16 20
17S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"