summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-02 11:01:05 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:24 -0700
commit59d36c9832702989bfcca8a5af29fb2dff01efcc (patch)
treeb2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-security/optee-imx/optee-os_3.10.0.imx.bb
parent72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff)
downloadmeta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-os_3.10.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-os_3.10.0.imx.bb36
1 files changed, 18 insertions, 18 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.10.0.imx.bb b/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
index 712b1aa6..dc0f1731 100644
--- a/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.10.0.imx.bb
@@ -22,23 +22,23 @@ inherit deploy python3native autotools
22 22
23# The platform flavor corresponds to the Yocto machine without the leading 'i'. 23# The platform flavor corresponds to the Yocto machine without the leading 'i'.
24PLATFORM_FLAVOR = "${@d.getVar('MACHINE')[1:]}" 24PLATFORM_FLAVOR = "${@d.getVar('MACHINE')[1:]}"
25PLATFORM_FLAVOR_imx6qpdlsolox = "mx6qsabresd" 25PLATFORM_FLAVOR:imx6qpdlsolox = "mx6qsabresd"
26PLATFORM_FLAVOR_imx6ul7d = "mx6ulevk" 26PLATFORM_FLAVOR:imx6ul7d = "mx6ulevk"
27PLATFORM_FLAVOR_imx6ull14x14evk = "mx6ullevk" 27PLATFORM_FLAVOR:imx6ull14x14evk = "mx6ullevk"
28PLATFORM_FLAVOR_imx6ull9x9evk = "mx6ullevk" 28PLATFORM_FLAVOR:imx6ull9x9evk = "mx6ullevk"
29PLATFORM_FLAVOR_imx6ulz-14x14-evk = "mx6ulzevk" 29PLATFORM_FLAVOR:imx6ulz-14x14-evk = "mx6ulzevk"
30PLATFORM_FLAVOR_mx8mq = "mx8mqevk" 30PLATFORM_FLAVOR:mx8mq = "mx8mqevk"
31PLATFORM_FLAVOR_mx8mm = "mx8mmevk" 31PLATFORM_FLAVOR:mx8mm = "mx8mmevk"
32PLATFORM_FLAVOR_mx8mn = "mx8mnevk" 32PLATFORM_FLAVOR:mx8mn = "mx8mnevk"
33PLATFORM_FLAVOR_mx8mp = "mx8mpevk" 33PLATFORM_FLAVOR:mx8mp = "mx8mpevk"
34PLATFORM_FLAVOR_mx8qm = "mx8qmmek" 34PLATFORM_FLAVOR:mx8qm = "mx8qmmek"
35PLATFORM_FLAVOR_mx8qxp = "mx8qxpmek" 35PLATFORM_FLAVOR:mx8qxp = "mx8qxpmek"
36PLATFORM_FLAVOR_mx8dx = "mx8dxmek" 36PLATFORM_FLAVOR:mx8dx = "mx8dxmek"
37PLATFORM_FLAVOR_mx8dxl = "mx8dxlevk" 37PLATFORM_FLAVOR:mx8dxl = "mx8dxlevk"
38 38
39OPTEE_ARCH ?= "arm32" 39OPTEE_ARCH ?= "arm32"
40OPTEE_ARCH_armv7a = "arm32" 40OPTEE_ARCH:armv7a = "arm32"
41OPTEE_ARCH_aarch64 = "arm64" 41OPTEE_ARCH:aarch64 = "arm64"
42 42
43# Optee-os can be built for 32 bits and 64 bits at the same time 43# Optee-os can be built for 32 bits and 64 bits at the same time
44# as long as the compilers are correctly defined. 44# as long as the compilers are correctly defined.
@@ -86,9 +86,9 @@ do_install () {
86addtask deploy after do_compile before do_install 86addtask deploy after do_compile before do_install
87 87
88 88
89FILES_${PN} = "${nonarch_base_libdir}/firmware/" 89FILES:${PN} = "${nonarch_base_libdir}/firmware/"
90FILES_${PN}-staticdev = "/usr/include/optee/" 90FILES:${PN}-staticdev = "/usr/include/optee/"
91RDEPENDS_${PN}-dev += "${PN}-staticdev" 91RDEPENDS:${PN}-dev += "${PN}-staticdev"
92 92
93PACKAGE_ARCH = "${MACHINE_ARCH}" 93PACKAGE_ARCH = "${MACHINE_ARCH}"
94COMPATIBLE_MACHINE = "(imx|imx-boot-container)" 94COMPATIBLE_MACHINE = "(imx|imx-boot-container)"