summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-os-fslc.inc
diff options
context:
space:
mode:
authorJun Zhu <junzhu@nxp.com>2024-10-21 09:04:29 +0800
committerJun Zhu <junzhu@nxp.com>2024-10-21 22:07:14 +0800
commiteaab26c60395a58ec3d93ffb411b958016471f77 (patch)
tree3f5fd2c2369601c154b3461342e6882925f2fccf /recipes-security/optee-imx/optee-os-fslc.inc
parent28aeeeb7ce3df60c6968ac3b3e977ce9587fbf32 (diff)
downloadmeta-freescale-eaab26c60395a58ec3d93ffb411b958016471f77.tar.gz
optee-os: work-around buildpaths QA error of staticdev
Fix the QA Error: ERROR: optee-os-4.2.0.imx-r0 do_package_qa: QA Issue: File /usr/include/optee/export-user_ta_arm64/lib/libutils.a in package optee-os-staticdev contains reference to TMPDIR [buildpaths] ERROR: optee-os-4.2.0.imx-r0 do_package_qa: QA Issue: File /usr/include/optee/export-user_ta_arm64/lib/libdl.a in package optee-os-staticdev contains reference to TMPDIR [buildpaths] ERROR: optee-os-4.2.0.imx-r0 do_package_qa: QA Issue: File /usr/include/optee/export-user_ta_arm64/lib/libmbedtls.a in package optee-os-staticdev contains reference to TMPDIR [buildpaths] ERROR: optee-os-4.2.0.imx-r0 do_package_qa: QA Issue: File /usr/include/optee/export-user_ta_arm64/lib/libutee.a in package optee-os-staticdev contains reference to TMPDIR [buildpaths] ERROR: optee-os-4.2.0.imx-r0 do_package_qa: Fatal QA errors were found, failing task. ERROR: Logfile of failure stored in: /../build-imx93-11x11-lpddr4x-evk/tmp/work/imx93_11x11_lpddr4x_evk-poky-linux/optee-os/4.2.0.imx/temp/log.do_package_qa.2422162 ERROR: Task (/../meta-freescale/recipes-security/optee-imx/optee-os_4.2.0.imx.bb:do_package_qa) failed with exit code '1' Signed-off-by: Jun Zhu <junzhu@nxp.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-os-fslc.inc')
-rw-r--r--recipes-security/optee-imx/optee-os-fslc.inc5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-security/optee-imx/optee-os-fslc.inc b/recipes-security/optee-imx/optee-os-fslc.inc
index b91a5531..61906344 100644
--- a/recipes-security/optee-imx/optee-os-fslc.inc
+++ b/recipes-security/optee-imx/optee-os-fslc.inc
@@ -1,4 +1,4 @@
1# Copyright (C) 2017-2021 NXP 1# Copyright (C) 2017-2021,2024 NXP
2 2
3SUMMARY = "OPTEE OS" 3SUMMARY = "OPTEE OS"
4DESCRIPTION = "OPTEE OS" 4DESCRIPTION = "OPTEE OS"
@@ -84,4 +84,7 @@ FILES:${PN} = "${nonarch_base_libdir}/firmware/ ${nonarch_base_libdir}/optee_arm
84FILES:${PN}-staticdev = "${includedir}/optee/" 84FILES:${PN}-staticdev = "${includedir}/optee/"
85RDEPENDS:${PN}-dev += "${PN}-staticdev" 85RDEPENDS:${PN}-dev += "${PN}-staticdev"
86 86
87# FIXME: Build paths are currently embedded
88INSANE_SKIP:${PN}-staticdev += "buildpaths"
89
87PACKAGE_ARCH = "${MACHINE_ARCH}" 90PACKAGE_ARCH = "${MACHINE_ARCH}"