summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2019-10-25 11:34:53 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-11-08 15:31:25 -0300
commitd331f7043142626ce2250ccd7f9a3e4791b1d377 (patch)
tree1899e6d8167b5fc52c98f5fa52aa557ed8e9537d /recipes-security/optee-imx/optee-client_3.2.0.imx.bb
parentc8b32341043831f4e8933b00ddf83831e7d015ce (diff)
downloadmeta-freescale-d331f7043142626ce2250ccd7f9a3e4791b1d377.tar.gz
optee-client: Add support for optee-client imx fork
This also includes some backported gcc 8 fixes from upstream. Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'recipes-security/optee-imx/optee-client_3.2.0.imx.bb')
-rw-r--r--recipes-security/optee-imx/optee-client_3.2.0.imx.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
new file mode 100644
index 00000000..2b0bcf48
--- /dev/null
+++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
@@ -0,0 +1,57 @@
1# Copyright (C) 2017-2018 NXP
2
3SUMMARY = "OPTEE Client libs"
4HOMEPAGE = "http://www.optee.org/"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
7
8inherit pythonnative systemd
9
10SRCBRANCH = "imx_4.14.78_1.0.0_ga"
11OPTEE_CLIENT_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https"
12SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}"
13
14SRCREV = "d06647d201520ac57f1331e97db6138d63bc2666"
15
16FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
17
18SRC_URI_append = " file://0001-libteec-refactor-_dprintf.patch \
19 file://tee-supplicant.service"
20
21S = "${WORKDIR}/git"
22SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
23
24EXTRA_OEMAKE = "CFG_SECURE_DATA_PATH=y"
25
26do_compile () {
27 if [ ${DEFAULTTUNE} = "aarch64" ]; then
28 oe_runmake -C ${S} ARCH=arm64
29 else
30 oe_runmake -C ${S} ARCH=arm
31 fi
32}
33
34do_install () {
35 oe_runmake install
36
37 install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
38 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
39 ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
40
41 install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant
42
43 cp -a ${S}/out/export/include ${D}/usr/
44
45 sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${WORKDIR}/tee-supplicant.service
46 install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service
47}
48
49PACKAGES += "tee-supplicant"
50FILES_${PN} += "${libdir}/* ${includedir}/*"
51FILES_tee-supplicant += "${bindir}/tee-supplicant"
52
53INSANE_SKIP_${PN} = "ldflags dev-elf"
54INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
55INSANE_SKIP_tee-supplicant = "ldflags"
56
57COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"