summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-11 10:27:46 -0800
committerKhem Raj <raj.khem@gmail.com>2023-03-11 17:48:48 -0800
commitf0ca145c90637c2c89027f5a00e36662b9e23e1b (patch)
treeeb4b635bd67adfcd801637c16ac2e6c78d26c277 /recipes-multimedia
parentd486bbf75ef95f3bf854a5490dbda164f03c39c3 (diff)
downloadmeta-freescale-f0ca145c90637c2c89027f5a00e36662b9e23e1b.tar.gz
gstreamer1.0-omx: Add 1.20.3.imx recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx_1.20.3.imx.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.20.3.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.20.3.imx.bb
new file mode 100644
index 00000000..dc1c8ba0
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.20.3.imx.bb
@@ -0,0 +1,52 @@
1SUMMARY = "OpenMAX IL plugins for GStreamer"
2DESCRIPTION = "Wraps available OpenMAX IL components and makes them available as standard GStreamer elements."
3HOMEPAGE = "http://gstreamer.freedesktop.org/"
4SECTION = "multimedia"
5
6LICENSE = "LGPL-2.1-or-later"
7LICENSE_FLAGS = "commercial"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
9 file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${@get_gst_ver('${PV}')}.tar.xz"
12
13SRC_URI[sha256sum] = "8db48040bb41f09edf8d17ff6d16c54888d7777ba4501c2c69f0083350ea9a15"
14
15S = "${WORKDIR}/gst-omx-${@get_gst_ver('${PV}')}"
16
17DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/libomxil"
18
19inherit meson pkgconfig upstream-version-is-even
20
21GSTREAMER_1_0_OMX_TARGET ?= "bellagio"
22GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0"
23
24EXTRA_OEMESON += "-Dtarget=${GSTREAMER_1_0_OMX_TARGET}"
25
26python __anonymous () {
27 omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET")
28 if omx_target in ['generic', 'bellagio']:
29 # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,#
30 # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros);
31 # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this
32 d.appendVar("CFLAGS", " -I${S}/omx/openmax")
33 elif omx_target == "rpi":
34 # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific
35 d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH"))
36}
37
38set_omx_core_name() {
39 sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf"
40}
41
42# Drop .imx from PV
43def get_gst_ver(v):
44 return oe.utils.trim_version(v, 3)
45
46do_install[postfuncs] += " set_omx_core_name "
47
48FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
49FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
50
51VIRTUAL-RUNTIME_libomxil ?= "libomxil"
52RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_libomxil}"