summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-12 19:45:04 -0700
committerKhem Raj <raj.khem@gmail.com>2023-03-12 19:45:04 -0700
commite7b24f8aefda47f95863154aa75cae2c81bd9dbe (patch)
tree2895c0d13f0d7ee3b7d60538f97c837fc53844fe /recipes-multimedia
parent7fd2ea865f954300d31fdfef3a5564f797cbe617 (diff)
downloadmeta-freescale-e7b24f8aefda47f95863154aa75cae2c81bd9dbe.tar.gz
gstreamer1.0-plugins-good: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-Add-prototype-declaration-for-gst_v4l2_object_stream.patch32
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-Add-prototype-declaration-for-gst_v4l2_object_stream.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-Add-prototype-declaration-for-gst_v4l2_object_stream.patch
new file mode 100644
index 00000000..0a6637de
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-Add-prototype-declaration-for-gst_v4l2_object_stream.patch
@@ -0,0 +1,32 @@
1From 50c821e3578e3e0892574d88ef7edb25d60ae50a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 19:39:46 -0700
4Subject: [PATCH] Add prototype declaration for gst_v4l2_object_streamoff
5
6Fixes build with latest compilers e.g. clang-16
7
8../git/sys/v4l2/gstv4l2videodec.c:354:10: error: call to undeclared function 'gst_v4l2_object_streamoff'; ISO C99 and later do not support implicit function declarations [ -Wimplicit-function-declaration]
9 if (!gst_v4l2_object_streamoff (self->v4l2capture))
10 ^
11
12Upstream-Status: Submitted [https://github.com/nxp-imx/gst-plugins-good/pull/1]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 sys/v4l2/gstv4l2object.h | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/sys/v4l2/gstv4l2object.h b/sys/v4l2/gstv4l2object.h
19index 685086902..c84dc1724 100644
20--- a/sys/v4l2/gstv4l2object.h
21+++ b/sys/v4l2/gstv4l2object.h
22@@ -323,6 +323,7 @@ GstStructure * gst_v4l2_object_v4l2fourcc_to_structure (guint32 fourcc);
23
24 /* crop / compose */
25 gboolean gst_v4l2_object_set_crop (GstV4l2Object * obj, struct v4l2_rect *result);
26+gboolean gst_v4l2_object_streamoff (GstV4l2Object * v4l2object);
27
28 /* TODO Move to proper namespace */
29 /* open/close the device */
30--
312.39.2
32
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb
index 8cbbd2d1..ccbf0196 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb
@@ -13,6 +13,7 @@ BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues
13 13
14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \ 14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
15 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \ 15 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \
16 file://0001-Add-prototype-declaration-for-gst_v4l2_object_stream.patch \
16 " 17 "
17 18
18SRC_URI[sha256sum] = "f8f3c206bf5cdabc00953920b47b3575af0ef15e9f871c0b6966f6d0aa5868b7" 19SRC_URI[sha256sum] = "f8f3c206bf5cdabc00953920b47b3575af0ef15e9f871c0b6966f6d0aa5868b7"