summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorZan Dobersek <zdobersek@igalia.com>2020-12-07 15:36:33 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-11 17:43:58 -0300
commitd2f7d17d562a90240effc358a1af52d5307eb195 (patch)
treeb5d5d7083f6804ad034b4c1ada4cb1f7d3ac5418 /recipes-multimedia
parent4371c3f165335be15a67c35d35c1aaec4be7ac70 (diff)
downloadmeta-freescale-d2f7d17d562a90240effc358a1af52d5307eb195.tar.gz
gstreamer1.0-plugins-base: update to NXP's MM_04.05.06_2008_L5.4.47 branch
Update gstreamer1.0-plugins-base package to use the MM_04.05.06_2008_L5.4.47 branch. This branch is based on the upstream 1.16.2 release which also includes one patch we until now maintained in this recipe. Signed-off-by: Zan Dobersek <zdobersek@igalia.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-Add-VideoMetas-and-GLSyncMeta-to-the-raw-up.patch87
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bb5
2 files changed, 2 insertions, 90 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-Add-VideoMetas-and-GLSyncMeta-to-the-raw-up.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-Add-VideoMetas-and-GLSyncMeta-to-the-raw-up.patch
deleted file mode 100644
index f891a63a..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-glupload-Add-VideoMetas-and-GLSyncMeta-to-the-raw-up.patch
+++ /dev/null
@@ -1,87 +0,0 @@
1From 8d32de090554cf29fe359f83aa46000ba658a693 Mon Sep 17 00:00:00 2001
2From: Thibault Saunier <tsaunier@igalia.com>
3Date: Fri, 27 Sep 2019 11:10:43 -0300
4Subject: [PATCH] glupload: Add VideoMetas and GLSyncMeta to the raw uploaded
5 buffers
6
7This is done by reusing `gst_gl_memory_setup_buffer` avoiding to
8duplicate code.
9
10Without a VideoMeta, mapping those buffers lead to GstBuffer mapping the
11buffer in system memory even when specifying the GL flags (through the
12buffer merging mechanism) making the result totally broken.
13
14Part-of: https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/444
15Upstream-Status: Backport [8d32de090554cf29fe359f83aa46000ba658a693]
16
17Signed-off-by: Zan Dobersek <zdobersek@igalia.com>
18---
19 gst-libs/gst/gl/gstglupload.c | 32 +++++++++++---------------------
20 tests/check/libs/gstglupload.c | 2 ++
21 2 files changed, 13 insertions(+), 21 deletions(-)
22
23diff --git a/gst-libs/gst/gl/gstglupload.c b/gst-libs/gst/gl/gstglupload.c
24index bc6db7e0a..67ec4f4e9 100644
25--- a/gst-libs/gst/gl/gstglupload.c
26+++ b/gst-libs/gst/gl/gstglupload.c
27@@ -1293,33 +1293,23 @@ _raw_data_upload_perform (gpointer impl, GstBuffer * buffer,
28 (raw->upload->context));
29
30 /* FIXME Use a buffer pool to cache the generated textures */
31- /* FIXME: multiview support with separated left/right frames? */
32 *outbuf = gst_buffer_new ();
33- for (i = 0; i < n_mem; i++) {
34- GstGLBaseMemory *tex;
35-
36- raw->params->parent.wrapped_data = raw->in_frame->frame.data[i];
37- raw->params->plane = i;
38- raw->params->tex_format =
39- gst_gl_format_from_video_info (raw->upload->context, in_info, i);
40-
41- tex =
42- gst_gl_base_memory_alloc (allocator,
43- (GstGLAllocationParams *) raw->params);
44- if (!tex) {
45- gst_buffer_unref (*outbuf);
46- *outbuf = NULL;
47- GST_ERROR_OBJECT (raw->upload, "Failed to allocate wrapped texture");
48- return GST_GL_UPLOAD_ERROR;
49- }
50+ raw->params->parent.context = raw->upload->context;
51+ if (gst_gl_memory_setup_buffer ((GstGLMemoryAllocator *) allocator, *outbuf,
52+ raw->params, NULL, raw->in_frame->frame.data, n_mem)) {
53
54- _raw_upload_frame_ref (raw->in_frame);
55- gst_buffer_append_memory (*outbuf, (GstMemory *) tex);
56+ for (i = 0; i < n_mem; i++)
57+ _raw_upload_frame_ref (raw->in_frame);
58+ gst_buffer_add_gl_sync_meta (raw->upload->context, *outbuf);
59+ } else {
60+ GST_ERROR_OBJECT (raw->upload, "Failed to allocate wrapped texture");
61+ gst_buffer_unref (*outbuf);
62+ return GST_GL_UPLOAD_ERROR;
63 }
64 gst_object_unref (allocator);
65-
66 _raw_upload_frame_unref (raw->in_frame);
67 raw->in_frame = NULL;
68+
69 return GST_GL_UPLOAD_DONE;
70 }
71
72diff --git a/tests/check/libs/gstglupload.c b/tests/check/libs/gstglupload.c
73index 74bff2b83..eff2f18ba 100644
74--- a/tests/check/libs/gstglupload.c
75+++ b/tests/check/libs/gstglupload.c
76@@ -281,6 +281,8 @@ GST_START_TEST (test_upload_data)
77 res = gst_gl_upload_perform_with_buffer (upload, inbuf, &outbuf);
78 fail_unless (res == GST_GL_UPLOAD_DONE, "Failed to upload buffer");
79 fail_unless (GST_IS_BUFFER (outbuf));
80+ fail_unless (gst_buffer_get_video_meta (outbuf));
81+ fail_unless (gst_buffer_get_gl_sync_meta (outbuf));
82
83 res = gst_buffer_map (outbuf, &map_info, GST_MAP_READ | GST_MAP_GL);
84 fail_if (res == FALSE, "Failed to map gl memory");
85--
862.28.0
87
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bb
index f8fc08fa..db0b740f 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.imx.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" 5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
6 6
7GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https" 7GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
8SRCBRANCH = "MM_04.05.05_2005_L5.4.24" 8SRCBRANCH = "MM_04.05.06_2008_L5.4.47"
9SRCREV = "cad00a3c4318c787c9661990e8f9328e4a69a329" 9SRCREV = "3c4aa2a58576d68f6e684efa58609665679c9969"
10SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \ 10SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
11 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \ 11 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
12 file://0001-gstreamer-plugins-base-fix-meson-build-in-nxp-fork.patch \ 12 file://0001-gstreamer-plugins-base-fix-meson-build-in-nxp-fork.patch \
@@ -14,7 +14,6 @@ SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
14 file://0005-viv-fb-Make-sure-config.h-is-included.patch \ 14 file://0005-viv-fb-Make-sure-config.h-is-included.patch \
15 file://0009-glimagesink-Downrank-to-marginal.patch \ 15 file://0009-glimagesink-Downrank-to-marginal.patch \
16 file://0001-gst-libs-gst-gl-wayland-fix-meson-build.patch \ 16 file://0001-gst-libs-gst-gl-wayland-fix-meson-build.patch \
17 file://0001-glupload-Add-VideoMetas-and-GLSyncMeta-to-the-raw-up.patch \
18 file://0001-meson-viv-fb-code-must-link-against-libg2d.patch \ 17 file://0001-meson-viv-fb-code-must-link-against-libg2d.patch \
19 " 18 "
20 19