summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-08-03 10:16:20 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-08-03 10:16:20 -0700
commitd15c1e8b06bd3299d264ea37d4ac5345c43f4706 (patch)
tree375a9cc8c53e680540a47221864647477d8d052b /recipes-multimedia
parentaf8bc52e026897d379609cc51d33f628583dcfee (diff)
downloadmeta-freescale-d15c1e8b06bd3299d264ea37d4ac5345c43f4706.tar.gz
gstreamer1.0-vaapi: Use egl for all i.MX GPU
i.MX 6 & 7 with GPU fails to build due to lack of glx support. Move the fix in 1.22.0.imx, which is limited to i.MX 8, to a generic bbappend so the upstream recipe is covered as well. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend1
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb9
2 files changed, 8 insertions, 2 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend
new file mode 100644
index 00000000..3b23818d
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_%.bbappend
@@ -0,0 +1 @@
PACKAGECONFIG_GL:imxgpu = "egl"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb
index 288de6c5..02dc86e4 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.22.0.imx.bb
@@ -32,8 +32,13 @@ def get_gst_ver(v):
32 32
33PACKAGES =+ "${PN}-tests" 33PACKAGES =+ "${PN}-tests"
34 34
35# Use egl for i.MX 35# OpenGL packageconfig factored out to make it easy for distros
36PACKAGECONFIG_GL ?= "egl" 36# and BSP layers to pick either glx, egl, or no GL. By default,
37# try detecting X11 first, and if found (with OpenGL), use GLX,
38# otherwise try to check if EGL can be used.
39PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
40 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
41 '', d), d)}"
37 42
38PACKAGECONFIG ??= "drm encoders \ 43PACKAGECONFIG ??= "drm encoders \
39 ${PACKAGECONFIG_GL} \ 44 ${PACKAGECONFIG_GL} \