summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2020-04-24 09:05:45 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-24 08:13:12 -0300
commitc3bdc608728223ac6d215da616196afea57168cd (patch)
treed331afceb8425777367bd547d752ce43b6300fd7 /recipes-multimedia
parent5d7e6fbe0e82895ec0b007b6e4dc725c26af290b (diff)
downloadmeta-freescale-c3bdc608728223ac6d215da616196afea57168cd.tar.gz
gstreamer1.0-plugins-imx: Update to version 0.13.1
* Last planned release in the 0.x series. Development now focuses on 2.x. The 2.x series will support i.MX6, i.MX7, and i.MX8. * OE recipe fix to use the correct G2D dependency (imxg2d, not imx-gpu-viv) * waf: Update to version 2.0.12 and switch to Python 3 * misc: * gst_buffer_pool_config_set_allocator() and get_allocator() are transfer-none. Changes to the code address that, fixing various refcount related problems. * Update GstPhysMemoryAllocator support for GStreamer 1.14+ * v4l2video: * v4l2src: Set interlace flags in GstBuffer * v4l2sink: Define V4L2_COLORSPACE_DEFAULT if it doesn't exist * v4l2: Add phys mem meta only if the driver/card is known to support this This makes USB video cameras work with imxv4l2videosrc, because they do not provide any physical address. * v4l2_buffer_pool: First reset the buffer storage in the pool, then queue the buffer. Otherwise it might happen that we dequeue the same buffer in a different thread already *before* we have it reset in the buffer storage, and then run into an assertion because it contains NULL. * vpu: * decoder: Fix for an endless loop at gst_imx_vpu_decoder_finish() when in no_wait mode * decoder: Clear the GST_VIDEO_BUFFER_FLAG_TFF flag in case of IMX_VPU_INTERLACING_MODE_BOTTOM_FIELD_FIRST * decoder: Honour num-additional-framebuffers setting * decoder: Fix leak when input video formats change due to a missing gst_imx_vpu_decoder_close() call * ipu: Reintroduce interlace methods * audio: * Save pointer to codec_data GstBuffer to fix memory leak * Only allocate reordered_channel_positions if needed. If we don't need to reorder the audio channels, we the unnecessary allocation otherwise. * g2dpango: * Add missing header and cleanup a few warnings * Unref video_frame memory after phys_memory check Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb)8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
index ce836df1..35996337 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_git.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
@@ -14,10 +14,10 @@ RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good"
14RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers" 14RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
15RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" 15RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
16 16
17PV = "0.13.0+git${SRCPV}" 17PV .= "+git${SRCPV}"
18 18
19SRCBRANCH ?= "master" 19SRCBRANCH ?= "master"
20SRCREV = "64485a1573f39a79f92688f9e32b2babab066b9d" 20SRCREV = "805987bff74af13fcb14ff111955206f1c92554d"
21SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" 21SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
@@ -50,8 +50,8 @@ PACKAGECONFIG_append_imxipu = " ipu"
50PACKAGECONFIG_append_imxvpu = " vpu" 50PACKAGECONFIG_append_imxvpu = " vpu"
51PACKAGECONFIG_append_imxpxp = " pxp" 51PACKAGECONFIG_append_imxpxp = " pxp"
52 52
53PACKAGECONFIG[g2d] = ",--disable-g2d,imx-gpu-viv" 53PACKAGECONFIG[g2d] = ",--disable-g2d,imx-gpu-g2d"
54PACKAGECONFIG[g2dpango] = ",--disable-g2dpango,imx-gpu-viv pango" 54PACKAGECONFIG[g2dpango] = ",--disable-g2dpango,imx-gpu-g2d pango"
55PACKAGECONFIG[pxp] = ",--disable-pxp," 55PACKAGECONFIG[pxp] = ",--disable-pxp,"
56PACKAGECONFIG[ipu] = ",--disable-ipu," 56PACKAGECONFIG[ipu] = ",--disable-ipu,"
57PACKAGECONFIG[vpu] = ",--disable-vpu,libimxvpuapi" 57PACKAGECONFIG[vpu] = ",--disable-vpu,libimxvpuapi"