summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-06-07 22:59:23 -0700
committerKhem Raj <raj.khem@gmail.com>2023-06-08 07:48:47 -0700
commita4a73ad3fd57a7ef8e7c8f4b7be3061020e66afb (patch)
tree97b05a6832d6fe1e12bb9ae724d0efef98ad517b /recipes-multimedia
parent07bcb512050210e1d1b58f814833e7b0c0cbf103 (diff)
downloadmeta-freescale-a4a73ad3fd57a7ef8e7c8f4b7be3061020e66afb.tar.gz
gstreamer1.0-plugins-good: Fix build with clang-16
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2-Include-gst-allocators-gstdmabuf.h-for-gst_is_d.patch32
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2-Include-gst-allocators-gstdmabuf.h-for-gst_is_d.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2-Include-gst-allocators-gstdmabuf.h-for-gst_is_d.patch
new file mode 100644
index 00000000..1345dd4f
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/0001-v4l2-Include-gst-allocators-gstdmabuf.h-for-gst_is_d.patch
@@ -0,0 +1,32 @@
1From dc5d752ec3fbec10402aa60fa8245e384e0c7206 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 7 Jun 2023 22:53:47 -0700
4Subject: [PATCH] v4l2: Include gst/allocators/gstdmabuf.h for
5 gst_is_dmabuf_memory()
6
7This is flagged by clang-16
8../git/sys/v4l2/gstv4l2videoenc.c:756:9: error: call to undeclared function 'gst_is_dmabuf_memory'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
9 if (gst_is_dmabuf_memory (gst_buffer_peek_memory (frame->input_buffer, 0))
10 ^
11
12Upstream-Status: Submitted [https://github.com/nxp-imx/gst-plugins-good/pull/2]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 sys/v4l2/gstv4l2videoenc.c | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/sys/v4l2/gstv4l2videoenc.c b/sys/v4l2/gstv4l2videoenc.c
19index a505a228f..f24d5a795 100644
20--- a/sys/v4l2/gstv4l2videoenc.c
21+++ b/sys/v4l2/gstv4l2videoenc.c
22@@ -36,6 +36,7 @@
23
24 #include <string.h>
25 #include <gst/gst-i18n-plugin.h>
26+#include <gst/allocators/gstdmabuf.h>
27
28 GST_DEBUG_CATEGORY_STATIC (gst_v4l2_video_enc_debug);
29 #define GST_CAT_DEFAULT gst_v4l2_video_enc_debug
30--
312.41.0
32
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb
index 95c8657e..95e33d5b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.20.3.imx.bb
@@ -13,6 +13,7 @@ BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues
13 13
14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \ 14SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
15 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \ 15 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \
16 file://0001-v4l2-Include-gst-allocators-gstdmabuf.h-for-gst_is_d.patch \
16 " 17 "
17 18
18SRC_URI[sha256sum] = "f8f3c206bf5cdabc00953920b47b3575af0ef15e9f871c0b6966f6d0aa5868b7" 19SRC_URI[sha256sum] = "f8f3c206bf5cdabc00953920b47b3575af0ef15e9f871c0b6966f6d0aa5868b7"