summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2016-10-13 09:59:53 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-10-27 10:36:28 -0200
commit86afc6c9e207989eeeccc405cee2f10277ca935e (patch)
tree31e88478508bda5ba6eead101adfa52f77fc8cb2 /recipes-multimedia
parentffe5d3c435a7f2056a1a594d195d624c20e40e0a (diff)
downloadmeta-freescale-86afc6c9e207989eeeccc405cee2f10277ca935e.tar.gz
gstreamer1.0-plugins-bad: work around for no frame when imxplayer using glimagesink
Workaround: Change parent window of internal_window in window_show function. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch63
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend1
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch
new file mode 100644
index 00000000..de53df42
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch
@@ -0,0 +1,63 @@
1From 61b6bc77cb939a778e2ddfee68d0378680f69f71 Mon Sep 17 00:00:00 2001
2From: Haihua Hu <b55597@freescale.com>
3Date: Wed, 9 Mar 2016 13:00:39 +0800
4Subject: [PATCH 18/18] glwindow: work around for no frame when imxplayer use
5 glimagesink
6
7change parent window of internal_window in window_show function.
8
9Upstream-Status: Inappropriate [i.MX specific]
10
11Signed-off-by: Haihua Hu <b55597@freescale.com>
12Signed-off-by: Lyon Wang <lyon.wang@freescale.com>
13---
14 gst-libs/gst/gl/x11/gstglwindow_x11.c | 14 +++++++++++---
15 1 file changed, 11 insertions(+), 3 deletions(-)
16
17diff --git a/gst-libs/gst/gl/x11/gstglwindow_x11.c b/gst-libs/gst/gl/x11/gstglwindow_x11.c
18index a330825..67160f6 100644
19--- a/gst-libs/gst/gl/x11/gstglwindow_x11.c
20+++ b/gst-libs/gst/gl/x11/gstglwindow_x11.c
21@@ -322,13 +322,13 @@ gst_gl_window_x11_set_window_handle (GstGLWindow * window, guintptr id)
22 g_main_context_get_thread_default ());
23 }
24
25- XGetWindowAttributes (window_x11->device, window_x11->parent_win, &attr);
26+ /*XGetWindowAttributes (window_x11->device, window_x11->parent_win, &attr);
27
28 XResizeWindow (window_x11->device, window_x11->internal_win_id,
29 attr.width, attr.height);
30
31 XReparentWindow (window_x11->device, window_x11->internal_win_id,
32- window_x11->parent_win, 0, 0);
33+ window_x11->parent_win, 0, 0);*/
34
35 XSync (window_x11->device, FALSE);
36 }
37@@ -359,7 +359,7 @@ _show_window (GstGLWindow * window)
38 GstGLWindowX11 *window_x11 = GST_GL_WINDOW_X11 (window);
39 guint width = window_x11->priv->preferred_width;
40 guint height = window_x11->priv->preferred_height;
41- XWindowAttributes attr;
42+ XWindowAttributes attr, parent_attr;
43
44 XGetWindowAttributes (window_x11->device, window_x11->internal_win_id, &attr);
45
46@@ -371,6 +371,14 @@ _show_window (GstGLWindow * window)
47 XResizeWindow (window_x11->device, window_x11->internal_win_id,
48 attr.width, attr.height);
49 XSync (window_x11->device, FALSE);
50+ }else{
51+ XGetWindowAttributes (window_x11->device, window_x11->parent_win, &parent_attr);
52+
53+ XResizeWindow (window_x11->device, window_x11->internal_win_id,
54+ parent_attr.width, parent_attr.height);
55+
56+ XReparentWindow (window_x11->device, window_x11->internal_win_id,
57+ window_x11->parent_win, 0, 0);
58 }
59
60 XMapWindow (window_x11->device, window_x11->internal_win_id);
61--
621.9.1
63
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index 08eec1e4..7fba6e21 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -15,6 +15,7 @@ SRC_URI_append = " file://0001-glplugin-Change-wayland-default-res-to-1024x768.p
15 file://0003-MMFMWK-6930-glplugin-Accelerate-gldownload-with-dire.patch \ 15 file://0003-MMFMWK-6930-glplugin-Accelerate-gldownload-with-dire.patch \
16 file://0004-Fix-dependence-issue-between-gst-plugin-.patch \ 16 file://0004-Fix-dependence-issue-between-gst-plugin-.patch \
17 file://0005-glcolorconvert-convert-YUV-to-RGB-use-directviv.patch \ 17 file://0005-glcolorconvert-convert-YUV-to-RGB-use-directviv.patch \
18 file://0006-glwindow-work-around-for-no-frame-when-imxplayer-use.patch \
18" 19"
19 20
20 21