summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-13 20:42:10 -0700
committerKhem Raj <raj.khem@gmail.com>2023-03-13 20:42:10 -0700
commit7e36025b115ef3221b2026bd432b572b8a5b76fd (patch)
tree41f79d35ed7329eb5b990e3237ff999671cb82c6 /recipes-multimedia
parentefbd4d5aa45fa568b04f0948266e6b6d90f958c0 (diff)
downloadmeta-freescale-7e36025b115ef3221b2026bd432b572b8a5b76fd.tar.gz
imx-gst1.0-plugin: Fix build with clang
These warnings are already there, gcc just does not error on them yet but clang does. Therefore clean them up a bit Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-aiurdemux-Fix-type-of-USER_DATA_LOCATION.patch33
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0002-aiurdemux.h-Include-glib-gprintf.h-for-g_printf-prot.patch28
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0003-grecorder-Fix-build-with-clang.patch44
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0004-gstimxcommon-Return-0-instead-of-NULL-for-a-function.patch87
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0005-aiurstreamcache-Include-gst-gstinfo.h.patch28
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0006-Fix-typecast-warnings-found-with-clang.patch61
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0007-gstimxv4l2-Fix-typecasting-errors.patch30
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0008-beepdec-Declare-beep_register_external_typefinders.patch32
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0009-gstimxv4l2.c-Fix-incompatible-integer-to-pointer-con.patch41
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin/0010-provide-declaration-for-aiur_register_external_typef.patch28
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb15
11 files changed, 426 insertions, 1 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-aiurdemux-Fix-type-of-USER_DATA_LOCATION.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-aiurdemux-Fix-type-of-USER_DATA_LOCATION.patch
new file mode 100644
index 00000000..bdcb3f48
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-aiurdemux-Fix-type-of-USER_DATA_LOCATION.patch
@@ -0,0 +1,33 @@
1From 090fb758a63b7d362d9bee8b8a665d1346c83f83 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Mar 2023 20:15:22 -0700
4Subject: [PATCH 01/10] aiurdemux: Fix type of USER_DATA_LOCATION
5
6It should be char pointer not integer
7Fixe
8plugins/aiurdemux/aiurdemux.c:198:47: error: incompatible integer to pointer conversion initializin
9g 'const gchar *' (aka 'const char *') with an expression of type 'int' [-Wint-conversion]
10 {USER_DATA_LOCATION, USER_DATA_FORMAT_UTF8, -1,
11 ^~
12Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 plugins/aiurdemux/aiurdemux.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/plugins/aiurdemux/aiurdemux.c b/plugins/aiurdemux/aiurdemux.c
19index 532b439..39c50ea 100755
20--- a/plugins/aiurdemux/aiurdemux.c
21+++ b/plugins/aiurdemux/aiurdemux.c
22@@ -195,7 +195,7 @@ static AiurDemuxTagEntry g_user_data_entry[] = {
23 "Track Number : %s\n"},
24 {USER_DATA_TOTALTRACKNUMBER, USER_DATA_FORMAT_UTF8, GST_TAG_TRACK_COUNT,
25 "Track Count : %s\n"},
26- {USER_DATA_LOCATION, USER_DATA_FORMAT_UTF8, -1,
27+ {USER_DATA_LOCATION, USER_DATA_FORMAT_UTF8, (const gchar*)-1,
28 "Location : %s\n"},
29 {USER_DATA_KEYWORDS, USER_DATA_FORMAT_UTF8, GST_TAG_KEYWORDS,
30 "Keywords : %s\n"},
31--
322.39.2
33
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0002-aiurdemux.h-Include-glib-gprintf.h-for-g_printf-prot.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0002-aiurdemux.h-Include-glib-gprintf.h-for-g_printf-prot.patch
new file mode 100644
index 00000000..d3fdf924
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0002-aiurdemux.h-Include-glib-gprintf.h-for-g_printf-prot.patch
@@ -0,0 +1,28 @@
1From f8b8322cd4c3a69e5cb47b5cb33abe860e89d6ed Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 20:33:54 -0700
4Subject: [PATCH 02/10] aiurdemux.h: Include glib/gprintf.h for g_printf
5 prototype
6
7Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 plugins/aiurdemux/aiurdemux.h | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/plugins/aiurdemux/aiurdemux.h b/plugins/aiurdemux/aiurdemux.h
14index 1d7d0a0..f7fcb2e 100755
15--- a/plugins/aiurdemux/aiurdemux.h
16+++ b/plugins/aiurdemux/aiurdemux.h
17@@ -39,7 +39,7 @@
18 #include <gst/gst.h>
19 #include <gst/base/gstadapter.h>
20 #include <gst/tag/tag.h>
21-
22+#include <glib/gprintf.h>
23 //#include "mfw_gst_utils.h"
24
25 #include "fsl_parser.h"
26--
272.39.2
28
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0003-grecorder-Fix-build-with-clang.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0003-grecorder-Fix-build-with-clang.patch
new file mode 100644
index 00000000..a690b497
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0003-grecorder-Fix-build-with-clang.patch
@@ -0,0 +1,44 @@
1From 19e6a541d2026386c9cfdeca0eebd269fef2536c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Mar 2023 20:29:01 -0700
4Subject: [PATCH 03/10] grecorder: Fix build with clang
5
6Add missing includes for APIs from libc and glib
7Add prototype declaration for post_message before
8using it in macros later in the same source file
9
10Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 tools/grecorder/grecorder.c | 5 ++++-
14 1 file changed, 4 insertions(+), 1 deletion(-)
15
16diff --git a/tools/grecorder/grecorder.c b/tools/grecorder/grecorder.c
17index c8eff2f..89aa801 100644
18--- a/tools/grecorder/grecorder.c
19+++ b/tools/grecorder/grecorder.c
20@@ -23,10 +23,11 @@
21 #include <semaphore.h>
22 #include <pthread.h>
23 #include <signal.h>
24+#include <unistd.h> /* sleep */
25 #include <getopt.h>
26 #define __USE_LARGEFILE64
27 #include <sys/statvfs.h>
28-
29+#include <glib/gprintf.h> /* g_print */
30 #include "recorder_engine.h"
31
32 #define LOG_ERROR printf
33@@ -168,6 +169,8 @@ static RecorderMessage latest_message = MESSAGE_NULL;
34
35 static volatile sig_atomic_t quit_flag = 0;
36
37+static void post_message (RecorderMessage message);
38+
39 static void signal_handler(int signum)
40 {
41 quit_flag = 1;
42--
432.39.2
44
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0004-gstimxcommon-Return-0-instead-of-NULL-for-a-function.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0004-gstimxcommon-Return-0-instead-of-NULL-for-a-function.patch
new file mode 100644
index 00000000..292ab63f
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0004-gstimxcommon-Return-0-instead-of-NULL-for-a-function.patch
@@ -0,0 +1,87 @@
1From 141f8f692ae2c7e6d41a2d78113c806602122ad5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 19:51:27 -0700
4Subject: [PATCH 04/10] gstimxcommon: Return 0 instead of NULL for a functions
5 returning unsigned long
6
7Fixes
8gstimxcommon.c:113:10: error: incompatible pointer to integer conversion returning 'void *' from a function with result type 'unsigned long' [-Wint-conversion]
9 return NULL;
10
11Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 libs/gstimxcommon.c | 18 +++++++++---------
15 1 file changed, 9 insertions(+), 9 deletions(-)
16
17diff --git a/libs/gstimxcommon.c b/libs/gstimxcommon.c
18index 27fd913..803c6e5 100644
19--- a/libs/gstimxcommon.c
20+++ b/libs/gstimxcommon.c
21@@ -35,13 +35,13 @@ unsigned long phy_addr_from_fd(int dmafd)
22 int ret, fd;
23
24 if (dmafd < 0)
25- return NULL;
26+ return 0;
27
28 #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 14, 0)
29 #ifdef USE_ION
30 fd = open(dev_ion, O_RDWR);
31 if(fd < 0) {
32- return NULL;
33+ return 0;
34 }
35
36 struct ion_phys_dma_data data = {
37@@ -58,18 +58,18 @@ unsigned long phy_addr_from_fd(int dmafd)
38 ret = ioctl(fd, ION_IOC_CUSTOM, &custom);
39 close(fd);
40 if (ret < 0)
41- return NULL;
42+ return 0;
43
44 return data.phys;
45 #else
46- return NULL;
47+ return 0;
48 #endif /* USE_ION */
49 #else
50 struct dma_buf_phys dma_phys;
51
52 ret = ioctl(dmafd, DMA_BUF_IOCTL_PHYS, &dma_phys);
53 if (ret < 0)
54- return NULL;
55+ return 0;
56
57 return dma_phys.phys;
58 #endif
59@@ -86,7 +86,7 @@ unsigned long phy_addr_from_vaddr(void *vaddr, int size)
60 #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 14, 0)
61 fd = open(dev_ion, O_RDWR);
62 if(fd < 0) {
63- return NULL;
64+ return 0;
65 }
66
67 struct ion_phys_virt_data data = {
68@@ -103,13 +103,13 @@ unsigned long phy_addr_from_vaddr(void *vaddr, int size)
69 ret = ioctl(fd, ION_IOC_CUSTOM, &custom);
70 close(fd);
71 if (ret < 0)
72- return NULL;
73+ return 0;
74
75 return data.phys;
76 #else
77- return NULL;
78+ return 0;
79 #endif
80 #else
81- return NULL;
82+ return 0;
83 #endif
84 }
85--
862.39.2
87
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0005-aiurstreamcache-Include-gst-gstinfo.h.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0005-aiurstreamcache-Include-gst-gstinfo.h.patch
new file mode 100644
index 00000000..5f67ba1b
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0005-aiurstreamcache-Include-gst-gstinfo.h.patch
@@ -0,0 +1,28 @@
1From 379b0492a4b53fd8fd42c734d04fd62df2e0465f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Mar 2023 20:16:48 -0700
4Subject: [PATCH 05/10] aiurstreamcache: Include gst/gstinfo.h
5
6Its needed for various GST_* defines
7
8Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 plugins/aiurdemux/aiurstreamcache.c | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/plugins/aiurdemux/aiurstreamcache.c b/plugins/aiurdemux/aiurstreamcache.c
15index d566268..e114a9d 100755
16--- a/plugins/aiurdemux/aiurstreamcache.c
17+++ b/plugins/aiurdemux/aiurstreamcache.c
18@@ -33,6 +33,7 @@
19 * Changelog:
20 *
21 */
22+ #include <gst/gstinfo.h>
23
24 GST_DEBUG_CATEGORY_EXTERN (aiurdemux_debug);
25 #define GST_CAT_DEFAULT aiurdemux_debug
26--
272.39.2
28
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0006-Fix-typecast-warnings-found-with-clang.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0006-Fix-typecast-warnings-found-with-clang.patch
new file mode 100644
index 00000000..ae3d1061
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0006-Fix-typecast-warnings-found-with-clang.patch
@@ -0,0 +1,61 @@
1From 02e16c4de3f138f0ebabf699e840bb86c98be599 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 20:45:23 -0700
4Subject: [PATCH 06/10] Fix typecast warnings found with clang
5
6Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 libs/device-2d/imx_2d_device_g2d.c | 15 ++++++++-------
10 1 file changed, 8 insertions(+), 7 deletions(-)
11
12diff --git a/libs/device-2d/imx_2d_device_g2d.c b/libs/device-2d/imx_2d_device_g2d.c
13index 2672e0b..6a36f6a 100755
14--- a/libs/device-2d/imx_2d_device_g2d.c
15+++ b/libs/device-2d/imx_2d_device_g2d.c
16@@ -425,7 +425,7 @@ static gint imx_g2d_blit(Imx2DDevice *device,
17 goto err;
18 }
19 if (paddr) {
20- src->mem->paddr = paddr;
21+ src->mem->paddr = (guint8*)paddr;
22 } else {
23 GST_ERROR ("Can't get physical address.");
24 ret = -1;
25@@ -435,7 +435,7 @@ static gint imx_g2d_blit(Imx2DDevice *device,
26 if (!dst->mem->paddr) {
27 paddr = phy_addr_from_fd (dst->fd[0]);
28 if (paddr) {
29- dst->mem->paddr = paddr;
30+ dst->mem->paddr = (guint8*)paddr;
31 } else {
32 GST_ERROR ("Can't get physical address.");
33 ret = -1;
34@@ -474,10 +474,11 @@ static gint imx_g2d_blit(Imx2DDevice *device,
35
36 if (src->fd[1] >= 0)
37 {
38- if (!src->mem->user_data)
39- src->mem->user_data = g2d->src.base.planes[1] = phy_addr_from_fd (src->fd[1]);
40- else
41- g2d->src.base.planes[1] = src->mem->user_data;
42+ if (!src->mem->user_data) {
43+ g2d->src.base.planes[1] = (gint)phy_addr_from_fd (src->fd[1]);
44+ src->mem->user_data = (gpointer *)g2d->src.base.planes[1];
45+ } else
46+ g2d->src.base.planes[1] = (unsigned long)src->mem->user_data;
47 }
48 switch (src->interlace_type) {
49 case IMX_2D_INTERLACE_INTERLEAVED:
50@@ -693,7 +694,7 @@ static gint imx_g2d_fill_color(Imx2DDevice *device, Imx2DFrame *dst,
51 if (!dst->mem->paddr) {
52 paddr = phy_addr_from_fd (dst->fd[0]);
53 if (paddr) {
54- dst->mem->paddr = paddr;
55+ dst->mem->paddr = (guint8*)paddr;
56 } else {
57 GST_ERROR ("Can't get physical address.");
58 return -1;
59--
602.39.2
61
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0007-gstimxv4l2-Fix-typecasting-errors.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0007-gstimxv4l2-Fix-typecasting-errors.patch
new file mode 100644
index 00000000..1983838a
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0007-gstimxv4l2-Fix-typecasting-errors.patch
@@ -0,0 +1,30 @@
1From a1a2069403e227d4d40fc99257d1be077f65bdc8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 19:54:18 -0700
4Subject: [PATCH 07/10] gstimxv4l2: Fix typecasting errors
5
6Fixes
7gstimxv4l2.c:1702:22: error: incompatible pointer to integer conversion assigning to 'unsigned long' from 'guint8 *' (aka 'unsigned char *') [-Wint-conversion]
8
9Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 libs/v4l2_core/gstimxv4l2.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/libs/v4l2_core/gstimxv4l2.c b/libs/v4l2_core/gstimxv4l2.c
16index 1dc826b..bf2620a 100755
17--- a/libs/v4l2_core/gstimxv4l2.c
18+++ b/libs/v4l2_core/gstimxv4l2.c
19@@ -1699,7 +1699,7 @@ gint gst_imx_v4l2_register_buffer (gpointer v4l2handle, PhyMemBlock *memblk)
20 v4l2buf->type = handle->type;
21 v4l2buf->memory = handle->memory_mode;
22 v4l2buf->index = handle->allocated;
23- v4l2buf->m.userptr = memblk->paddr;
24+ v4l2buf->m.userptr = (unsigned long)memblk->paddr;
25 v4l2buf->length = memblk->size;
26 handle->buffer_pair[handle->allocated].vaddr = memblk->vaddr;
27
28--
292.39.2
30
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0008-beepdec-Declare-beep_register_external_typefinders.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0008-beepdec-Declare-beep_register_external_typefinders.patch
new file mode 100644
index 00000000..211bade1
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0008-beepdec-Declare-beep_register_external_typefinders.patch
@@ -0,0 +1,32 @@
1From e86c20fee52f79a270a1913c5f0be98fb3f5cb77 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Mar 2023 20:18:18 -0700
4Subject: [PATCH 08/10] beepdec: Declare beep_register_external_typefinders
5
6Fixes
7plugins/beepdec/beep.c:45:3: error: call to undeclared function 'beep_register_external_typefinders'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
8 beep_register_external_typefinders (plugin);
9 ^
10
11Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 plugins/beepdec/beep.c | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/plugins/beepdec/beep.c b/plugins/beepdec/beep.c
18index 3543352..e174bb3 100755
19--- a/plugins/beepdec/beep.c
20+++ b/plugins/beepdec/beep.c
21@@ -37,7 +37,7 @@
22 #endif
23 #include "beepdec.h"
24 #include "gstimxcommon.h"
25-
26+extern gboolean beep_register_external_typefinders (GstPlugin * plugin);
27 static gboolean
28 plugin_init (GstPlugin * plugin)
29 {
30--
312.39.2
32
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0009-gstimxv4l2.c-Fix-incompatible-integer-to-pointer-con.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0009-gstimxv4l2.c-Fix-incompatible-integer-to-pointer-con.patch
new file mode 100644
index 00000000..567d1026
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0009-gstimxv4l2.c-Fix-incompatible-integer-to-pointer-con.patch
@@ -0,0 +1,41 @@
1From 8a3d7f26c73bdfe050d3331b30ae2f5917dc6723 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 19:59:22 -0700
4Subject: [PATCH 09/10] gstimxv4l2.c: Fix incompatible integer to pointer
5 conversion returning
6
7Fixes
8gstimxv4l2.c:1587:24: error: incompatible pointer to integer conversion assigning to 'unsigned long' from 'guint8 *' (aka 'unsigned char *') [-Wint-c
9onversion]
10
11Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 libs/v4l2_core/gstimxv4l2.c | 4 ++--
15 1 file changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/libs/v4l2_core/gstimxv4l2.c b/libs/v4l2_core/gstimxv4l2.c
18index bf2620a..0fd7452 100755
19--- a/libs/v4l2_core/gstimxv4l2.c
20+++ b/libs/v4l2_core/gstimxv4l2.c
21@@ -1576,7 +1576,7 @@ static void * gst_imx_v4l2_find_buffer(gpointer v4l2handle, PhyMemBlock *memblk)
22
23 if (handle->allocated >= MAX_BUFFER) {
24 GST_ERROR ("No more v4l2 buffer for allocating.\n");
25- return -1;
26+ return NULL;
27 }
28
29 v4l2buf = &handle->buffer_pair[handle->allocated].v4l2buffer;
30@@ -1584,7 +1584,7 @@ static void * gst_imx_v4l2_find_buffer(gpointer v4l2handle, PhyMemBlock *memblk)
31 v4l2buf->type = handle->type;
32 v4l2buf->memory = handle->memory_mode;
33 v4l2buf->index = handle->allocated;
34- v4l2buf->m.userptr = memblk->paddr;
35+ v4l2buf->m.userptr = (unsigned long)memblk->paddr;
36 v4l2buf->length = memblk->size;
37 handle->buffer_pair[handle->allocated].vaddr = memblk->vaddr;
38
39--
402.39.2
41
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0010-provide-declaration-for-aiur_register_external_typef.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0010-provide-declaration-for-aiur_register_external_typef.patch
new file mode 100644
index 00000000..e9b1a093
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0010-provide-declaration-for-aiur_register_external_typef.patch
@@ -0,0 +1,28 @@
1From c2144da90e64547d9e346f8e721a0d2155ed610b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 12 Mar 2023 21:09:49 -0700
4Subject: [PATCH 10/10] provide declaration for
5 aiur_register_external_typefinders
6
7Upstream-Status: Submitted [https://github.com/nxp-imx/imx-gst1.0-plugin/pull/4]
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 plugins/aiurdemux/aiur.c | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/plugins/aiurdemux/aiur.c b/plugins/aiurdemux/aiur.c
14index 2a52465..681ae2e 100755
15--- a/plugins/aiurdemux/aiur.c
16+++ b/plugins/aiurdemux/aiur.c
17@@ -41,6 +41,8 @@
18 #include "aiurdemux.h"
19 #include "gstimxcommon.h"
20
21+extern gboolean aiur_register_external_typefinders (GstPlugin * plugin);
22+
23 static gboolean
24 plugin_init (GstPlugin * plugin)
25 {
26--
272.39.2
28
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
index cdd5d848..33b8e918 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_git.bb
@@ -25,7 +25,18 @@ LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
25 25
26PV = "4.7.2+git${SRCPV}" 26PV = "4.7.2+git${SRCPV}"
27 27
28SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH}" 28SRC_URI = "git://github.com/nxp-imx/imx-gst1.0-plugin.git;protocol=https;branch=${SRCBRANCH} \
29 file://0001-aiurdemux-Fix-type-of-USER_DATA_LOCATION.patch \
30 file://0002-aiurdemux.h-Include-glib-gprintf.h-for-g_printf-prot.patch \
31 file://0003-grecorder-Fix-build-with-clang.patch \
32 file://0004-gstimxcommon-Return-0-instead-of-NULL-for-a-function.patch \
33 file://0005-aiurstreamcache-Include-gst-gstinfo.h.patch \
34 file://0006-Fix-typecast-warnings-found-with-clang.patch \
35 file://0007-gstimxv4l2-Fix-typecasting-errors.patch \
36 file://0008-beepdec-Declare-beep_register_external_typefinders.patch \
37 file://0009-gstimxv4l2.c-Fix-incompatible-integer-to-pointer-con.patch \
38 file://0010-provide-declaration-for-aiur_register_external_typef.patch \
39 "
29SRCBRANCH = "MM_04.07.02_2210_L5.15.y" 40SRCBRANCH = "MM_04.07.02_2210_L5.15.y"
30SRCREV = "3a0250b983f2610e6936d10c63b45e2d39eadd7e" 41SRCREV = "3a0250b983f2610e6936d10c63b45e2d39eadd7e"
31 42
@@ -43,6 +54,8 @@ PLATFORM:mx7ulp-nxp-bsp= "MX7ULP"
43PLATFORM:mx8-nxp-bsp = "MX8" 54PLATFORM:mx8-nxp-bsp = "MX8"
44PLATFORM:mx9-nxp-bsp = "MX9" 55PLATFORM:mx9-nxp-bsp = "MX9"
45 56
57CFLAGS:append:toolchain-clang = " -Wno-implicit-int -Wno-int-conversion -Wno-incompatible-function-pointer-types"
58
46# Todo add a mechanism to map possible build targets 59# Todo add a mechanism to map possible build targets
47EXTRA_OEMESON = "-Dplatform=${PLATFORM} \ 60EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
48 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \ 61 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \