summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2023-07-30 13:56:06 +0200
committerCarlos Rafael Giani <crg7475@mailbox.org>2023-08-01 11:45:46 +0200
commit3022b7cbdfcc05bfdbe0b6b318eb9a107d9ce240 (patch)
treedd72628458950f7579030be3d6c242f195c0eac5 /recipes-multimedia
parent568cdfec59a93c93279397a1a839bd01d89ed453 (diff)
downloadmeta-freescale-3022b7cbdfcc05bfdbe0b6b318eb9a107d9ce240.tar.gz
libimxvpuapi2: Upgrade to version 2.3.0
* vpu: Implement first working version of VC8000E encoder integration This adds support for the Hanto VC8000E encoder that can be found on the i.MX8m plus. The VC8000E encoder integration is not finished. h.264 encoding works fine. h.265 encoding is not yet done. And, changing framerate mid-stream is currently not supported. * Replace mxcfb.h with ipu.h in option description Some BSPs no longer ship with the mxcfb.h header. * imx6-coda: Fix ENC_ENABLE_SOF_STUFF check The check was being performed incorrectly, leading to nullbytes being inserted at the end of the SOF0 marker. * imx6-coda: Insert JFIF APP0 segment The VPU does not insert this segment on its own. Some programs need JFIF data to be present in JPEG files, so insert APP0 manually. * imx6-coda: Fix decoder and encoder alignments * imx6-coda: Add more IPU detiler logging * imx6-coda: Fix decoder Y/U/V offset alignments As it turns out, these must be aligned to 8-byte boundaries, not to 4096 byte ones. The latter caused incorrect offset calculations. Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb (renamed from recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb)7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb
index b7f43a61..1e7d8252 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb
@@ -4,11 +4,14 @@ LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
5SECTION = "multimedia" 5SECTION = "multimedia"
6DEPENDS = "virtual/imxvpu libimxdmabuffer" 6DEPENDS = "virtual/imxvpu libimxdmabuffer"
7# Add imx-vpu-hantro-vc as dependency for being
8# able to encode video using the VC8000E encoder
9DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
7 10
8PV .= "+git${SRCPV}" 11PV .= "+git${SRCPV}"
9 12
10SRCBRANCH ?= "master" 13SRCBRANCH ?= "master"
11SRCREV = "b6486118d47937cd717c4881158dda6e72cf2855" 14SRCREV = "6f803f46d6b53a08cf02fc3d440072e01e2f3a09"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https" 15SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
13 16
14S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
@@ -18,7 +21,7 @@ inherit waf pkgconfig use-imx-headers
18IMX_PLATFORM:mx6-nxp-bsp = "imx6" 21IMX_PLATFORM:mx6-nxp-bsp = "imx6"
19IMX_PLATFORM:mx8mq-nxp-bsp = "imx8m" 22IMX_PLATFORM:mx8mq-nxp-bsp = "imx8m"
20IMX_PLATFORM:mx8mm-nxp-bsp = "imx8mm" 23IMX_PLATFORM:mx8mm-nxp-bsp = "imx8mm"
21IMX_PLATFORM:mx8mp-nxp-bsp = "imx8m" 24IMX_PLATFORM:mx8mp-nxp-bsp = "imx8mp"
22 25
23EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}" 26EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}"
24 27