diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-09-02 15:52:55 -0500 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-09-05 11:50:05 +0000 |
commit | cc026b37007884e2118b75fc81cca2c7e83ac0c4 (patch) | |
tree | 331ff4458576731ea9d2723acfc2f72498ec376c /recipes-multimedia/pulseaudio | |
parent | f6460dd4364e5743e87fedcc3d5b2658f3908ecd (diff) | |
download | meta-freescale-cc026b37007884e2118b75fc81cca2c7e83ac0c4.tar.gz |
pulseaudio: Fix gstreamer pause mutex issuebackport-1193-to-kirkstone
Add a patch to fix a mutex issue when pausing a gstreamer stream.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
(cherry picked from commit 791b2cd871e670f2cd691aad21a1c9bcffc362d6)
Diffstat (limited to 'recipes-multimedia/pulseaudio')
-rw-r--r-- | recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0001-Fix-pulseaudio-mutex-issue-when-do-pause-in-gstreame.patch | 32 | ||||
-rw-r--r-- | recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0100-pulseaudio-remove-the-control-for-speaker-headphone-widge.patch (renamed from recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch) | 0 | ||||
-rw-r--r-- | recipes-multimedia/pulseaudio/pulseaudio_%.bbappend | 21 |
3 files changed, 45 insertions, 8 deletions
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0001-Fix-pulseaudio-mutex-issue-when-do-pause-in-gstreame.patch b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0001-Fix-pulseaudio-mutex-issue-when-do-pause-in-gstreame.patch new file mode 100644 index 00000000..12a04cb7 --- /dev/null +++ b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0001-Fix-pulseaudio-mutex-issue-when-do-pause-in-gstreame.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From c21e24f5c53e81fc715905c54a6c82b69e397e63 Mon Sep 17 00:00:00 2001 | ||
2 | From: "shengjiu.wang" <b02247@freescale.com> | ||
3 | Date: Thu, 3 Apr 2014 14:22:02 +0800 | ||
4 | Subject: [PATCH] Fix pulseaudio mutex issue when do pause in gstreamer | ||
5 | |||
6 | The error log is "Assertion 'pthread_mutex_unlock(&m->mutex) == 0' | ||
7 | failed at pulsecore/mutex-posix.c:106, function pa_mutex_unlock(). Aborting" | ||
8 | |||
9 | This fix is a workaround base on the solution from this link " | ||
10 | https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/932096" | ||
11 | |||
12 | Upstream status: Inappropriate [i.MX specific] | ||
13 | Signed-off-by: shengjiu.wang <b02247@freescale.com> | ||
14 | --- | ||
15 | src/pulsecore/mutex-posix.c | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/src/pulsecore/mutex-posix.c b/src/pulsecore/mutex-posix.c | ||
19 | index 36c2787..d592501 100644 | ||
20 | --- a/src/pulsecore/mutex-posix.c | ||
21 | +++ b/src/pulsecore/mutex-posix.c | ||
22 | @@ -30,6 +30,7 @@ | ||
23 | #include <pulsecore/macro.h> | ||
24 | |||
25 | #include "mutex.h" | ||
26 | +#undef HAVE_PTHREAD_PRIO_INHERIT | ||
27 | |||
28 | struct pa_mutex { | ||
29 | pthread_mutex_t mutex; | ||
30 | -- | ||
31 | 1.7.9.5 | ||
32 | |||
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0100-pulseaudio-remove-the-control-for-speaker-headphone-widge.patch index 57c28741..57c28741 100644 --- a/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch +++ b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/0100-pulseaudio-remove-the-control-for-speaker-headphone-widge.patch | |||
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend index c7a4292e..69a9ec6b 100644 --- a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend +++ b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend | |||
@@ -1,13 +1,18 @@ | |||
1 | |||
2 | CACHED_CONFIGUREVARS:append:mx6-nxp-bsp = " ax_cv_PTHREAD_PRIO_INHERIT=no" | ||
3 | |||
4 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/imx-nxp-bsp:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/imx-nxp-bsp:" |
5 | 2 | ||
6 | SRC_URI:append:mx6-nxp-bsp = " file://daemon.conf file://default.pa" | 3 | SRC_URI += "${SRC_URI_IMX}" |
7 | SRC_URI:append:mx7-nxp-bsp = " file://daemon.conf file://default.pa \ | 4 | SRC_URI_IMX = "" |
8 | file://pulseaudio-remove-the-control-for-speaker-headphone-widge.patch \ | 5 | SRC_URI_IMX:mx6-nxp-bsp = " \ |
9 | " | 6 | file://0001-Fix-pulseaudio-mutex-issue-when-do-pause-in-gstreame.patch \ |
10 | SRC_URI:append:mx8-nxp-bsp = " file://daemon.conf file://default.pa" | 7 | file://daemon.conf \ |
8 | file://default.pa" | ||
9 | SRC_URI_IMX:mx7-nxp-bsp = " \ | ||
10 | ${SRC_URI_IMX:mx6-nxp-bsp} \ | ||
11 | file://0100-pulseaudio-remove-the-control-for-speaker-headphone-widge.patch" | ||
12 | SRC_URI_IMX:mx8-nxp-bsp = " \ | ||
13 | ${SRC_URI_IMX:mx6-nxp-bsp}" | ||
14 | |||
15 | CACHED_CONFIGUREVARS:append:mx6-nxp-bsp = " ax_cv_PTHREAD_PRIO_INHERIT=no" | ||
11 | 16 | ||
12 | do_install:append() { | 17 | do_install:append() { |
13 | if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then | 18 | if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then |