summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libimxvpuapi
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2019-07-23 13:49:23 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-08-06 11:26:36 -0300
commitd3ca2d6eb189794c9dbf29d261a3f5c539591241 (patch)
tree28e7267b5077778c35a712eedc5795bc51859d60 /recipes-multimedia/libimxvpuapi
parentfd1a2df923f933ec9d5065fcc19856f8df67e765 (diff)
downloadmeta-freescale-d3ca2d6eb189794c9dbf29d261a3f5c539591241.tar.gz
libimxvpuapi2: Add recipe
This is the successor to libimxvpuapi. Since at this moment, there is software still using the former, its recipe remains in place. Both versions (1 and 2) can coexist on the same rootfs. Version 2 introduces support for i.MX8 (mx8m and mx8mm for now), and also still supports i.MX6. Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-multimedia/libimxvpuapi')
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_git.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_git.bb
new file mode 100644
index 00000000..0ebeabb0
--- /dev/null
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_git.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "frontend for the i.MX6 / i.MX8 VPU hardware video engines"
2HOMEPAGE = "https://github.com/Freescale/libimxvpuapi"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
5SECTION = "multimedia"
6DEPENDS = "virtual/imxvpu libimxdmabuffer"
7
8PV = "2.0.0+${SRCPV}"
9
10SRCBRANCH ?= "master"
11SRCREV = "86028967644d2da8e99d4e206ca1d71ff4bcb7f7"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}"
13
14S = "${WORKDIR}/git"
15
16inherit waf pkgconfig use-imx-headers
17
18IMX_PLATFORM_mx6 = "imx6"
19IMX_PLATFORM_mx8mq = "imx8m"
20IMX_PLATFORM_mx8mm = "imx8mm"
21
22EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25COMPATIBLE_MACHINE = "(imxvpu)"