summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-09-30 16:52:38 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-01 14:53:16 -0300
commitaac087e42024c290adf34d93ce57a3e8ace2c23f (patch)
tree726901010cf09417fdb508df797377e102961ad4 /recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb
parente129edaedde7d4e828e2e186a6d34cb923d38bb9 (diff)
downloadmeta-freescale-aac087e42024c290adf34d93ce57a3e8ace2c23f.tar.gz
imx-vpuwrap: Upgrade version form 4.4.0 to 4.4.2
Add support for i.MX8MMEVK Update EULA to V26 Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb')
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb
new file mode 100644
index 00000000..f6d8be91
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.4.2.bb
@@ -0,0 +1,32 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2017 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6DEPENDS = "virtual/imxvpu"
7LICENSE = "Proprietary"
8SECTION = "multimedia"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
10
11# For backwards compatibility
12PROVIDES += "libfslvpuwrap"
13RREPLACES_${PN} = "libfslvpuwrap"
14RPROVIDES_${PN} = "libfslvpuwrap"
15RCONFLICTS_${PN} = "libfslvpuwrap"
16
17SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
18
19SRC_URI[md5sum] = "86d1829ef62ab51e187479bfea686874"
20SRC_URI[sha256sum] = "85f01ebdf55e4bd7a7cc21eb5203dfcaa7b663f03ecdb8d5e54fbb995e3dc761"
21
22inherit fsl-eula-unpack autotools pkgconfig
23
24do_install_append() {
25 # FIXME: Drop examples for now
26 rm -r ${D}${datadir}
27}
28
29INSANE_SKIP_imx-vpuwrap = "file-rdeps"
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(mx6q|mx6dl|mx8mq|mx8mm)"