summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-parser
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2016-04-18 22:57:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-05-07 10:07:46 -0300
commit03730c26904466db2a71413de1e7f89922e92679 (patch)
treebb041b187175951a6d7f8fd26ee28da5cc64ab3a /recipes-multimedia/imx-parser
parent5c2685be4871c2cffeb58988c323cde6d6f7e687 (diff)
downloadmeta-freescale-03730c26904466db2a71413de1e7f89922e92679.tar.gz
imx-parser: Upgrade to v4.0.9
--Change the recipe name from "libfslparser" to "imx-parser" --Add RREPLACE/RPROVIDES/RCONFLICTS for backwards compatibility. --Add aac latm parser in parser_libs, support aac latm in mpeg2 parser Change-Id: I2e3cb92a952fe10136c25206f1527ca1472598cc Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/imx-parser')
-rw-r--r--recipes-multimedia/imx-parser/imx-parser.inc38
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.0.9.bb9
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser.inc b/recipes-multimedia/imx-parser/imx-parser.inc
new file mode 100644
index 00000000..6fb34de8
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser.inc
@@ -0,0 +1,38 @@
1# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
2# Copyright (C) 2012-2016 Freescale Semiconductor
3# Released under the MIT license (see COPYING.MIT for the terms)
4DESCRIPTION = "Freescale Multimedia parser libs"
5LICENSE = "Proprietary"
6SECTION = "multimedia"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"
8
9# For backwards compatibility
10RREPLACES_${PN} = "libfslparser"
11RPROVIDES_${PN} = "libfslparser"
12RCONFLICTS_${PN} = "libfslparser"
13
14inherit fsl-eula-unpack autotools pkgconfig
15
16SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
17
18# Choose between Soft Float-Point and Hard Float-Point
19EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d)}"
20
21INHIBIT_PACKAGE_STRIP = "1"
22INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
23
24python __set_insane_skip() {
25 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
26 # the source we cannot fix it. Disable the insane check for now.
27 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
28 for p in d.getVar('PACKAGES', True).split():
29 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel")
30}
31
32do_package_qa[prefuncs] += "__set_insane_skip"
33
34# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
35FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
36
37PACKAGE_ARCH = "${MACHINE_ARCH}"
38
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.0.9.bb b/recipes-multimedia/imx-parser/imx-parser_4.0.9.bb
new file mode 100644
index 00000000..16501726
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser_4.0.9.bb
@@ -0,0 +1,9 @@
1# Copyright (C) 2013-2015 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require imx-parser.inc
5
6SRC_URI[md5sum] = "184687baede96fe3919196c3f91d907c"
7SRC_URI[sha256sum] = "1bec0101843db2e95d61e3dbe9e35172d874e54be19cc5d8bf72a735d5e3236f"
8
9COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"