summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer
diff options
context:
space:
mode:
authorVincent Dehors <vincent.dehors@smile.fr>2019-03-04 09:24:03 +0100
committerVincent Dehors <vincent.dehors@smile.fr>2019-03-19 11:17:14 +0100
commit5b35bca70f67d9e8bcb02859ba09ed16287db8d7 (patch)
tree57243c528f17f3d92f2108072e4bcf4fc421bb21 /recipes-multimedia/gstreamer
parent4ee590743c3c897724c5add273ab04518fece770 (diff)
downloadmeta-freescale-5b35bca70f67d9e8bcb02859ba09ed16287db8d7.tar.gz
recipes-multimedia/gstreamer: Fix compilation with OpenCV 3.4.5
This commit fixes the compilation of gstreamer1.0-plugins-bad which failed with : from ../../../git/ext/opencv/gstgrabcut.cpp:90: [...] error: conflicting declaration of C function 'CvMoments cvMoments(const cv::Moments&) The added patch is similar to 0001-opencv-fix-build-for-opencv-3-4-2.patch but for gstgrabcut.cpp.
Diffstat (limited to 'recipes-multimedia/gstreamer')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch40
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch
new file mode 100644
index 00000000..4c9cba61
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch
@@ -0,0 +1,40 @@
1From 70661ec35ba7655b52f4043ee7362202bc632472 Mon Sep 17 00:00:00 2001
2From: Vincent Dehors <vincent.dehors@smile.fr>
3Date: Mon, 4 Mar 2019 09:01:37 +0100
4Subject: [PATCH] opencv: Fix build with opencv >= 3.4.5
5
6Including C header imgproc_c.h leads to a compilation error : several
7conflicting declartions for cvMoments(). Including the HPP fixes this error
8as it is done in other CPP files in the same directory.
9
10Upstream-Status: Inappropriate, code ported to C++ in more recent version
11Signed-off-by: Vincent DEHORS <vincent.dehors@smile.fr>
12
13---
14 ext/opencv/gstgrabcut.cpp | 9 +++++----
15 1 file changed, 5 insertions(+), 4 deletions(-)
16
17diff --git a/ext/opencv/gstgrabcut.cpp b/ext/opencv/gstgrabcut.cpp
18index 4cbc706d5..65b508f20 100644
19--- a/ext/opencv/gstgrabcut.cpp
20+++ b/ext/opencv/gstgrabcut.cpp
21@@ -85,11 +85,12 @@
22 #endif
23
24 #include "gstgrabcut.h"
25-extern "C"
26-{
27+
28+#if (CV_MAJOR_VERSION >= 3)
29+#include <opencv2/imgproc.hpp>
30+#endif
31 #include <opencv2/imgproc/imgproc_c.h>
32-}
33-#include <opencv2/imgproc/imgproc.hpp>
34+
35 GST_DEBUG_CATEGORY_STATIC (gst_grabcut_debug);
36 #define GST_CAT_DEFAULT gst_grabcut_debug
37
38--
392.20.1
40
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
index 2e3f3469..9d7a1eed 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
@@ -24,6 +24,7 @@ SRC_URI = " \
24 file://configure-allow-to-disable-libssh2.patch \ 24 file://configure-allow-to-disable-libssh2.patch \
25 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \ 25 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
26 file://0001-opencv-fix-build-for-opencv-3-4-2.patch \ 26 file://0001-opencv-fix-build-for-opencv-3-4-2.patch \
27 file://0002-opencv-Fix-build-with-opencv-3.4.5.patch \
27" 28"
28 29
29SRCREV = "03e6ef6a371a0578a9629abde8e9c83e66f34b11" 30SRCREV = "03e6ef6a371a0578a9629abde8e9c83e66f34b11"