summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-04-04 20:23:10 -0300
committerGitHub <noreply@github.com>2022-04-04 20:23:10 -0300
commitb6514bbbe3c1643d55fb42241759cfe2e9dd0a35 (patch)
tree2d10b15b96f19b2529947992947fd6204eff9077 /recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb
parent36589d57ee3fa9d3aac891f42c16d45622b00750 (diff)
parent1c6c0f6523c0a62c15ac973aa782e108a652a61e (diff)
downloadmeta-freescale-b6514bbbe3c1643d55fb42241759cfe2e9dd0a35.tar.gz
Merge pull request #1032 from thochstein/master
gstreamer: Upgrade 1.18.0.imx -> 1.18.5.imx
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb101
1 files changed, 101 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb
new file mode 100644
index 00000000..3aabcf2d
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.5.imx.bb
@@ -0,0 +1,101 @@
1# This recipe is for the i.MX fork of gstreamer1.0. For ease of
2# maintenance, the top section is a verbatim copy of an OE-core
3# recipe. The second section customizes the recipe for i.MX.
4
5########### OE-core copy ##################
6# Upstream hash: bb6ddc3691ab04162ec5fd69a2d5e7876713fd15
7
8SUMMARY = "GStreamer 1.0 multimedia framework"
9DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
10It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
11HOMEPAGE = "http://gstreamer.freedesktop.org/"
12BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
13SECTION = "multimedia"
14LICENSE = "LGPL-2.0-or-later"
15
16DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
17
18inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection ptest-gnome
19
20LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
21 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
22
23S = "${WORKDIR}/gstreamer-${PV}"
24
25SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
26 file://run-ptest \
27 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
28 file://0002-Remove-unused-valgrind-detection.patch \
29 file://0003-tests-seek-Don-t-use-too-strict-timeout-for-validati.patch \
30 file://0004-tests-respect-the-idententaion-used-in-meson.patch \
31 file://0005-tests-add-support-for-install-the-tests.patch \
32 file://0006-tests-use-a-dictionaries-for-environment.patch \
33 file://0007-tests-install-the-environment-for-installed_tests.patch \
34 "
35SRC_URI[sha256sum] = "9aeec99b38e310817012aa2d1d76573b787af47f8a725a65b833880a094dfbc5"
36
37PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
38 check \
39 debug \
40 tools"
41
42PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
43PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
44PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled"
45PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
46PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
47PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
48PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
49PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
50PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
51PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
52
53# TODO: put this in a gettext.bbclass patch
54def gettext_oemeson(d):
55 if d.getVar('USE_NLS') == 'no':
56 return '-Dnls=disabled'
57 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
58 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
59 return '-Dnls=disabled'
60 return '-Dnls=enabled'
61
62EXTRA_OEMESON += " \
63 -Ddoc=disabled \
64 -Dexamples=disabled \
65 -Ddbghelp=disabled \
66 ${@gettext_oemeson(d)} \
67"
68
69GIR_MESON_ENABLE_FLAG = "enabled"
70GIR_MESON_DISABLE_FLAG = "disabled"
71
72PACKAGES += "${PN}-bash-completion"
73
74# Add the core element plugins to the main package
75FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
76FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
77FILES:${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
78FILES:${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
79
80CVE_PRODUCT = "gstreamer"
81
82PTEST_BUILD_HOST_FILES = ""
83
84########### End of OE-core copy ###########
85
86########### i.MX overrides ################
87
88DEFAULT_PREFERENCE = "-1"
89
90# Use i.MX fork of GST for customizations
91SRC_URI:remove = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz"
92GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https"
93SRCBRANCH = "MM_04.06.04_2112_L5.15.y"
94SRC_URI:prepend = "${GST1.0_SRC};branch=${SRCBRANCH} "
95SRCREV = "a55998c70940bd183d25d29e1b82fd3bc9f43df3"
96
97S = "${WORKDIR}/git"
98
99COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
100
101########### End of i.MX overrides #########