summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-08-06 17:23:30 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-09-07 17:23:09 -0300
commit680d8e12c8a3a3e9dfdd33e00fca0328c890eac9 (patch)
tree3eb851b9278cf04ae7504f5955524cfbd805f9f4 /recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
parentdf0d9963d41032c77d625c02070f5f06aac04e0a (diff)
downloadmeta-freescale-680d8e12c8a3a3e9dfdd33e00fca0328c890eac9.tar.gz
gstreamer1.0: Upgrade to v1.14.imx
Bugfix/Optimization: baseparse: Handle base parse error. baseparse: Unset FLAG_DISCONT when push to adapter. Or the DISCONT flag will always be set on each frame, for the first chain in buffer. baseparse: Push adapter remainning data in pass through mode to avoid missing data. poll: Need check if can read event of buffer for video decoder based on V4L2 driver. Add the API for it. inputselector: Proceed non-active pad buffer even if active pad reach eos Non-active pad will be blocked if active pad reach eos in inputselector, which will cause all pipeline be blocked. Inputselector should proceed non-active pad buffer based on clock even if active pad reach eos. Change to sync with clock for better user experience. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
new file mode 100644
index 00000000..a9012234
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.14.imx.bb
@@ -0,0 +1,76 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native elfutils"
10
11inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc
12
13# This way common/m4/introspection.m4 will come first
14# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file)
15acpaths = "-I ${S}/common/m4 -I ${S}/m4"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
18 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
19
20# Use i.MX fork of GST for customizations
21GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https"
22SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2"
23
24SRC_URI = " \
25 ${GST1.0_SRC};branch=${SRCBRANCH} \
26 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
27 file://gtk-doc-tweaks.patch \
28 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
29"
30SRCREV = "f4e127a5e9a1eb977e023532d6636d939c8ccbc8"
31
32DEFAULT_PREFERENCE = "-1"
33
34EXTRA_AUTORECONF = ""
35
36PACKAGECONFIG ??= ""
37
38PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
39PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
40PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
41PACKAGECONFIG[gst-tracer-hooks] = "--enable-gst-tracer-hooks,--disable-gst-tracer-hooks,"
42
43EXTRA_OECONF = " \
44 --disable-dependency-tracking \
45 --disable-examples \
46"
47
48CACHED_CONFIGUREVARS += "ac_cv_header_valgrind_valgrind_h=no"
49
50# musl libc generates warnings if <sys/poll.h> is included directly
51CACHED_CONFIGUREVARS += "ac_cv_header_sys_poll_h=no"
52
53PACKAGES += "${PN}-bash-completion"
54
55FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
56FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
57FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
58
59RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
60RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
61
62delete_pkg_m4_file() {
63 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
64 rm "${S}/common/m4/pkg.m4" || true
65 rm -f "${S}/common/m4/gtk-doc.m4"
66}
67
68do_configure[prefuncs] += "delete_pkg_m4_file"
69
70do_compile_prepend() {
71 export GIR_EXTRA_LIBS_PATH="${B}/gst/.libs:${B}/libs/gst/base/.libs"
72}
73
74S = "${WORKDIR}/git"
75
76COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"