summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-01 15:44:24 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-01 21:14:21 -0300
commit156064f4b778ceb595aa18e9e7209f2969069ed7 (patch)
tree2ff918fe93b876c319dd925728b6eb779de21b55 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
parentd9bba1d950e686fadf103d401662f85def45ae26 (diff)
downloadmeta-freescale-156064f4b778ceb595aa18e9e7209f2969069ed7.tar.gz
gstreamer1.0*: Fix versions for i.MX fork recipes
The gstreamer1.0 recipes for the i.MX forks were updated to a newer version, but the file versions were not updated accordingly. For the NXP 5.4.47 release, the gstreamer version is 1.16.2.imx. For NXP 5.4.70, the gstreamer version is 1.16.3.imx. Note that the original version 1.16.imx was not appropriate either, and this fix can also be viewed from that perspective, that the third digit of the version should be included in the recipe version. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb79
1 files changed, 0 insertions, 79 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
deleted file mode 100644
index 8413bf10..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
+++ /dev/null
@@ -1,79 +0,0 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2
3
4GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https"
5SRCBRANCH = "MM_04.05.07_2011_L5.4.70"
6
7SRC_URI = " \
8 ${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} \
9"
10SRCREV = "6005e8199ea19878f269b058ffbbbcaa314472d8"
11
12DEFAULT_PREFERENCE = "-1"
13
14S = "${WORKDIR}/git"
15
16LICENSE = "GPLv2+ & LGPLv2.1+"
17LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
18 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
19 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
20
21DEPENDS += "gstreamer1.0-plugins-base libcap zlib"
22RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
23RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
24
25PACKAGECONFIG ??= " \
26 ${GSTREAMER_ORC} \
27 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
28 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 \
29"
30
31X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
32X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
33X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
34
35PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
36PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
37PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394"
38PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
39PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
40PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3"
41PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev"
42PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
43PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
44PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
45PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng"
46PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
47PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
48PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
49PACKAGECONFIG[soup] = "-Dsoup=enabled,-Dsoup=disabled,libsoup-2.4"
50PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex"
51PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib"
52PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false,libdrm"
53PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx"
54PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
55PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
56
57# qt5 support is disabled, because it is not present in OE core, and requires more work than
58# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
59# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
60# in a gstreamer1.0-plugins-good bbappend).
61
62EXTRA_OEMESON += " \
63 -Daalib=disabled \
64 -Ddirectsound=disabled \
65 -Ddv=disabled \
66 -Dlibcaca=disabled \
67 -Doss=enabled \
68 -Doss4=disabled \
69 -Dosxaudio=disabled \
70 -Dosxvideo=disabled \
71 -Dqt5=disabled \
72 -Dshout2=disabled \
73 -Dtwolame=disabled \
74 -Dwaveform=disabled \
75"
76
77FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
78
79COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"