summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-08-06 17:23:31 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-09-07 17:24:35 -0300
commit13bdb940a49f3ac9c32d909368f84bcdae71d341 (patch)
tree62246245822d76351ebf451226c380419d2e0362 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
parent680d8e12c8a3a3e9dfdd33e00fca0328c890eac9 (diff)
downloadmeta-freescale-13bdb940a49f3ac9c32d909368f84bcdae71d341.tar.gz
gstreamer1.0-plugins-base: Upgrade to v1.14.imx
Add GST_GL_API ahead api to export symbol add include "gstglfuncs.h" when need call gl api. Add ion dmabuf support in glupload/gldownload. Add fullRange to hdr10 metadata. Move gstimxcommon.h into base for imx specified dev. Add imx physical memory allocator. Fix glplugin not build in wayland backend. Patch update to fix applying conflicts. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
new file mode 100644
index 00000000..3ea3d571
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.imx.bb
@@ -0,0 +1,77 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
7
8GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
9SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2"
10
11SRC_URI = " \
12 ${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
13 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
14 file://make-gio_unix_2_0-dependency-configurable.patch \
15 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
16 file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
17 file://0003-riff-add-missing-include-directories-when-calling-in.patch \
18 file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
19"
20SRCREV = "04bafd740a52757f12496206cfabe282835a1eb5"
21
22DEFAULT_PREFERENCE = "-1"
23
24EXTRA_AUTORECONF = ""
25
26S = "${WORKDIR}/git"
27
28# Enable pango lib
29PACKAGECONFIG_append = " pango "
30
31# Disable introspection to fix [GstGL-1.0.gir] Error
32EXTRA_OECONF_append = " --disable-introspection --disable-opengl --enable-wayland"
33
34# ion allocator will be enabled only when detecting the ion.h exists, which is built out from kernel.
35# Now, ion allocator can be supported on all i.MX platform
36DEPENDS_append = " iso-codes util-linux virtual/kernel"
37
38inherit gettext
39
40PACKAGES_DYNAMIC =+ "^libgst.*"
41
42PACKAGECONFIG ??= " \
43 ${GSTREAMER_ORC} \
44 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
45 ogg pango theora vorbis \
46"
47
48X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
49X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm"
50X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm"
51
52PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
53PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
54PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor"
55PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg"
56PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus"
57PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
58PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
59PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual"
60PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
61PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
62
63EXTRA_OECONF += " \
64 --enable-zlib \
65"
66
67CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
68
69FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
70
71do_compile_prepend() {
72 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs"
73}
74
75FILES_${PN} += "${libdir}/gstreamer-1.0/include"
76
77COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"