summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-01 15:44:24 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-01 21:14:21 -0300
commit156064f4b778ceb595aa18e9e7209f2969069ed7 (patch)
tree2ff918fe93b876c319dd925728b6eb779de21b55 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
parentd9bba1d950e686fadf103d401662f85def45ae26 (diff)
downloadmeta-freescale-156064f4b778ceb595aa18e9e7209f2969069ed7.tar.gz
gstreamer1.0*: Fix versions for i.MX fork recipes
The gstreamer1.0 recipes for the i.MX forks were updated to a newer version, but the file versions were not updated accordingly. For the NXP 5.4.47 release, the gstreamer version is 1.16.2.imx. For NXP 5.4.70, the gstreamer version is 1.16.3.imx. Note that the original version 1.16.imx was not appropriate either, and this fix can also be viewed from that perspective, that the third digit of the version should be included in the recipe version. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb175
1 files changed, 0 insertions, 175 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
deleted file mode 100644
index 8064d430..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
+++ /dev/null
@@ -1,175 +0,0 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2
3DEPENDS_append_imxgpu2d = " virtual/libg2d"
4DEPENDS_append_mx8 = " libdrm"
5
6PACKAGECONFIG_append_mx8 = " kms"
7
8DEFAULT_PREFERENCE = "-1"
9
10PACKAGE_ARCH_imxpxp = "${MACHINE_SOCARCH}"
11PACKAGE_ARCH_mx8 = "${MACHINE_SOCARCH}"
12
13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https"
14SRCBRANCH = "MM_04.05.07_2011_L5.4.70"
15
16SRC_URI = " \
17 ${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} \
18 file://0001-ext-wayland-fix-meson-build-in-nxp-fork.patch \
19 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
20 file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \
21 file://0001-opencv-allow-compilation-against-4.4.x.patch \
22 file://0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch \
23 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \
24 file://avoid-including-sys-poll.h-directly.patch \
25 file://ensure-valid-sentinels-for-gst_structure_get-etc.patch \
26"
27SRCREV = "cf7f2d0125424ce0d63ddc7f1eadc9ef71d10db1"
28
29S = "${WORKDIR}/git"
30
31LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
32LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
33 file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 "
34
35DEPENDS += "gstreamer1.0-plugins-base"
36
37inherit gobject-introspection
38
39PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
40PACKAGECONFIG_GL_imxpxp = "gles2"
41
42PACKAGECONFIG ??= " \
43 ${GSTREAMER_ORC} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
45 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
47 ${PACKAGECONFIG_GL} \
48 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \
49 ttml uvch264 webp \
50"
51
52PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass"
53PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5"
54PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
55PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo"
56PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl"
57PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2"
58PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394"
59PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb"
60PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl"
61PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac"
62PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2"
63PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth"
64PACKAGECONFIG[hls] = "-Dhls=enabled -Dhls-crypto=nettle,-Dhls=disabled,nettle"
65# the gl packageconfig enables OpenGL elements that haven't been ported
66# to -base yet. They depend on the gstgl library in -base, so we do
67# not add GL dependencies here, since these are taken care of in -base.
68PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled,"
69PACKAGECONFIG[gles2] = ",,virtual/libgles2"
70PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm"
71PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265"
72PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms"
73PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2"
74PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug"
75PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk"
76PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon"
77PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft"
78PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv"
79PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264"
80PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg"
81PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt"
82# the opus encoder/decoder elements are now in the -base package,
83# but the opus parser remains in -bad
84PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus"
85PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav"
86PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg"
87PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump"
88PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc"
89PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled,usrsctp"
90PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2"
91PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
92PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp"
93PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa"
94PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo"
95PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev"
96PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc"
97PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc"
98PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader"
99PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm"
100PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
101PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice"
102PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing"
103PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar"
104
105# Following package config in not available in NXP fork:
106#PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms"
107
108# these plugins currently have no corresponding library in OE-core or meta-openembedded:
109# aom androidmedia applemedia bs2b chromaprint d3dvideosink
110# directsound dts fdkaac gme gsm iq kate ladspa lv2 mpeg2enc
111# mplex musepack nvdec nvenc ofa openexr openni2 opensles
112# soundtouch spandsp srt teletext vdpau wasapi wildmidi winks
113# winscreencap wpe x265
114
115EXTRA_OEMESON += " \
116 -Ddecklink=enabled \
117 -Ddvb=enabled \
118 -Dfbdev=enabled \
119 -Dipcpipeline=enabled \
120 -Dnetsim=enabled \
121 -Dshm=enabled \
122 -Daom=disabled \
123 -Dandroidmedia=disabled \
124 -Dapplemedia=disabled \
125 -Dbs2b=disabled \
126 -Dchromaprint=disabled \
127 -Dd3dvideosink=disabled \
128 -Ddirectsound=disabled \
129 -Ddts=disabled \
130 -Dfdkaac=disabled \
131 -Dflite=disabled \
132 -Dgme=disabled \
133 -Dgsm=disabled \
134 -Diqa=disabled \
135 -Dkate=disabled \
136 -Dladspa=disabled \
137 -Dlv2=disabled \
138 -Dmpeg2enc=disabled \
139 -Dmplex=disabled \
140 -Dmsdk=disabled \
141 -Dmusepack=disabled \
142 -Dnvdec=disabled \
143 -Dnvenc=disabled \
144 -Dofa=disabled \
145 -Dopenexr=disabled \
146 -Dopenmpt=disabled \
147 -Dopenni2=disabled \
148 -Dopensles=disabled \
149 -Dsoundtouch=disabled \
150 -Dspandsp=disabled \
151 -Dsrt=disabled \
152 -Dteletext=disabled \
153 -Dvdpau=disabled \
154 -Dwasapi=disabled \
155 -Dwildmidi=disabled \
156 -Dwinks=disabled \
157 -Dwinscreencap=disabled \
158 -Dwpe=disabled \
159 -Dx265=disabled \
160 -Dzbar=disabled \
161 ${@bb.utils.contains("TUNE_FEATURES", "mx32", "-Dyadif=disabled", "", d)} \
162"
163
164export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}"
165
166ARM_INSTRUCTION_SET_armv4 = "arm"
167ARM_INSTRUCTION_SET_armv5 = "arm"
168
169FILES_${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs"
170FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*"
171FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
172# include fragment shaders
173FILES_${PN}-opengl += "/usr/share/*.fs"
174
175COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"