summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-30 15:03:02 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-04-04 16:57:41 -0500
commitb43b7a038e314256170992fba02f77611d949f36 (patch)
tree2284c23ced87c1a9a1cf93ef3aae00967eb7afcd /recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
parent01ad835b7d50a10c3e3cbfd9509fd32f8dbc293a (diff)
downloadmeta-freescale-b43b7a038e314256170992fba02f77611d949f36.tar.gz
gstreamer1.0-plugins-bad: Upgrade 1.18.0.imx -> 1.18.5.imx
Also separate the base recipe copy from the overrides for ease of maintenance. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
deleted file mode 100644
index 5e6a1c05..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1From 9e092d8976db034a2d6848d738c4f73cc001fd09 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Sun, 26 Jan 2020 10:45:28 +0000
4Subject: [PATCH] ext/wayland: fix meson build in nxp fork
5
6- Add Wayland protocols, which are not enabled in upstream
7- Add missing compilation unit, which in NXP-specific
8
9Upstream-Status: Pending
10
11Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
12
13---
14 ext/wayland/meson.build | 24 ++++++++++++++++++++++++
15 1 file changed, 24 insertions(+)
16
17diff --git a/ext/wayland/meson.build b/ext/wayland/meson.build
18index 3c377eefb..98a7cb76f 100644
19--- a/ext/wayland/meson.build
20+++ b/ext/wayland/meson.build
21@@ -10,6 +10,11 @@ wl_sources = [
22
23 libdrm_dep = dependency('libdrm', version: '>= 2.4.55', required:get_option('wayland'))
24
25+imx_wl_sources = [
26+ 'wlutils.c',
27+]
28+wl_sources += imx_wl_sources
29+
30 if use_wayland
31 protocols_datadir = wl_protocol_dep.get_pkgconfig_variable('pkgdatadir')
32
33@@ -21,6 +26,25 @@ if use_wayland
34 'fullscreen-shell-unstable-v1-protocol.c', 'fullscreen-shell-unstable-v1-client-protocol.h'],
35 ['/stable/xdg-shell/xdg-shell.xml', 'xdg-shell-protocol.c', 'xdg-shell-client-protocol.h'],
36 ]
37+
38+ imx_protocol_defs = [
39+ [
40+ '/unstable/alpha-compositing/alpha-compositing-unstable-v1.xml',
41+ 'alpha-compositing-unstable-v1-protocol.c',
42+ 'alpha-compositing-unstable-v1-client-protocol.h'
43+ ],
44+ ['/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml',
45+ 'hdr10-metadata-unstable-v1-protocol.c',
46+ 'hdr10-metadata-unstable-v1-client-protocol.h'
47+ ],
48+ [
49+ '/unstable/linux-explicit-synchronization/linux-explicit-synchronization-unstable-v1.xml',
50+ 'linux-explicit-synchronization-unstable-v1-protocol.c',
51+ 'linux-explicit-synchronization-unstable-v1-client-protocol.h'
52+ ],
53+ ]
54+ protocol_defs += imx_protocol_defs
55+
56 protocols_files = []
57
58 foreach protodef: protocol_defs